Approved changes feed: RSS · Atom

cpe:2.3:a:w1.fi:wpa_supplicant:0.7.0:*:*:*:*:*:*:*

part: a version: 0.7.0 update: *

VendorW1.Fi (dd38874c-a76b-597a-9161-ce551d4988f7)
ProductWpa Supplicant (8fd3742d-e589-50c6-bd53-a700a423d23b)
Edition*
Language*
Software edition*
Target software*
Target hardware*
Other*

Notes

Imported from NVD CPE 2.0 feed

PURL mappings

PURLSourceLast updated
pkg:github/cozybit/wpa_supplicant-o11s-legacy purl2cpe 2026-06-01 10:11:13.538218
pkg:github/digsrc/wpa_supplicant purl2cpe 2026-06-01 10:11:13.538219
pkg:github/mcgrof/wpa_supplicant purl2cpe 2026-06-01 10:11:13.538221
pkg:rpm/fedora/wpa_supplicant purl2cpe 2026-06-01 10:11:13.538223

Vulnerability references

IdentifiercpeApplicabilitySubmitteddb.gcve.eu detailsRationale
CVE:CVE-2015-4142 vulnerable 2026-06-08 05:06:39.245187 Details available
Integer underflow in the WMM Action frame parser in hostapd 0.5.5 through 2.4 and wpa_supplicant 0.7.0 through 2.4, when used for AP mode MLME/SME functionality, allows remote attackers to cause a denial of service (crash) via a crafted frame, which triggers an out-of-bounds read.
Published: 2015-06-15T15:00:00.000Z
Updated: 2024-08-06T06:04:02.867Z
Reference links
Imported from gcve-enriched-dumps CVE data
CVE:CVE-2015-4141 vulnerable 2026-06-08 05:06:39.232431 Details available
The WPS UPnP function in hostapd, when using WPS AP, and wpa_supplicant, when using WPS external registrar (ER), 0.7.0 through 2.4 allows remote attackers to cause a denial of service (crash) via a negative chunk length, which triggers an out-of-bounds read or heap-based buffer overflow.
Published: 2015-06-15T15:00:00.000Z
Updated: 2024-08-06T06:04:03.193Z
Reference links
Imported from gcve-enriched-dumps CVE data

Contribute

You can submit an edit proposal for this CPE entry or suggest a related product/vendor addition using the action button above.

Inspect record JSON

Open JSON directly

Open this panel to browse, search, copy or download the JSON record.