Approved changes feed: RSS · Atom

cpe:2.3:a:blueyonder:postgraas_server:2.0.0:beta1:*:*:*:*:*:*

part: a version: 2.0.0 update: beta1

VendorBlueyonder (74ca72f2-26e2-5fd7-ad6a-cf90363a46c6)
ProductPostgraas Server (39c46134-2585-5611-899d-7c38eb7e4b98)
Edition*
Language*
Software edition*
Target software*
Target hardware*
Other*

Notes

Imported from NVD CPE 2.0 feed

PURL mappings

PURLSourceLast updated
pkg:github/blue-yonder/postgraas_server purl2cpe 2026-06-01 10:11:30.477074
pkg:pypi/postgraas-server purl2cpe 2026-06-01 10:11:30.477076

Vulnerability references

IdentifiercpeApplicabilitySubmitteddb.gcve.eu detailsRationale
CVE:CVE-2018-25088 vulnerable 2026-06-08 05:11:29.345947 Blue Yonder postgraas_server PostgreSQL Backend postgres_cluster_driver.py create_postgres_db sql injection
MEDIUM (5.5)
A vulnerability, which was classified as critical, was found in Blue Yonder postgraas_server up to 2.0.0b2. Affected is the function _create_pg_connection/create_postgres_db of the file postgraas_server/backends/postgres_cluster/postgres_cluster_driver.py of the component PostgreSQL Backend Handler. The manipulation leads to sql injection. Upgrading to version 2.0.0 is able to address this issue. The patch is identified as 7cd8d016edc74a78af0d81c948bfafbcc93c937c. It is recommended to upgrade the affected component. VDB-234246 is the identifier assigned to this vulnerability.
Published: 2023-07-18T13:00:05.652Z
Updated: 2024-08-05T12:33:49.158Z
Reference links
Imported from gcve-enriched-dumps CVE data

Contribute

You can submit an edit proposal for this CPE entry or suggest a related product/vendor addition using the action button above.

Inspect record JSON

Open JSON directly

Open this panel to browse, search, copy or download the JSON record.