Approved changes feed: RSS · Atom

cpe:2.3:a:grocy_project:grocy:4.0.3:*:*:*:*:*:*:*

part: a version: 4.0.3 update: *

VendorGrocy Project (45dd3f2f-5960-58b1-9ff7-b58449ca2a97)
ProductGrocy (914ed8ae-c5ec-5f1c-a72f-01437b3c1179)
Edition*
Language*
Software edition*
Target software*
Target hardware*
Other*

Notes

Imported from NVD CPE 2.0 feed

PURL mappings

PURLSourceLast updated
pkg:github/grocy/grocy purl2cpe 2026-06-01 10:11:11.721006

Vulnerability references

IdentifiercpeApplicabilitySubmitteddb.gcve.eu detailsRationale
CVE:CVE-2023-48200 vulnerable 2026-06-08 06:14:26.131721 Details available
Cross Site Scripting vulnerability in Grocy v.4.0.3 allows a local attacker to execute arbitrary code and obtain sensitive information via the equipment description component within /equipment/ component.
Published: 2023-11-15T00:00:00.000Z
Updated: 2025-09-29T14:12:05.480Z
Reference links
Imported from gcve-enriched-dumps CVE data
CVE:CVE-2023-48199 vulnerable 2026-06-08 06:14:26.131358 Details available
HTML Injection vulnerability in the 'manageApiKeys' component in Grocy <= 4.0.3 allows attackers to inject arbitrary HTML content without script execution. This occurs when user-supplied data is not appropriately sanitized, enabling the injection of HTML tags through parameter values. The attacker can then manipulate page content in the QR code detail popup, often coupled with social engineering tactics, exploiting both the trust of users and the application's lack of proper input handling.
Published: 2023-11-15T00:00:00.000Z
Updated: 2025-09-29T14:08:09.008Z
Reference links
Imported from gcve-enriched-dumps CVE data
CVE:CVE-2023-48198 vulnerable 2026-06-08 06:14:26.130856 Details available
A Cross-Site Scripting (XSS) vulnerability in the 'product description' component within '/api/stock/products' of Grocy version <= 4.0.3 allows attackers to obtain a victim's cookies.
Published: 2023-11-15T00:00:00.000Z
Updated: 2025-09-29T14:05:18.106Z
Reference links
Imported from gcve-enriched-dumps CVE data
CVE:CVE-2023-48197 vulnerable 2026-06-08 06:14:26.130297 Details available
Cross-Site Scripting (XSS) vulnerability in the ‘manageApiKeys’ component of Grocy 4.0.3 and earlier allows attackers to obtain victim's cookies when the victim clicks on the "see QR code" function.
Published: 2023-11-15T00:00:00.000Z
Updated: 2025-09-29T13:59:05.001Z
Reference links
Imported from gcve-enriched-dumps CVE data

Contribute

You can submit an edit proposal for this CPE entry or suggest a related product/vendor addition using the action button above.

Inspect record JSON

Open JSON directly

Open this panel to browse, search, copy or download the JSON record.