Approved changes feed: RSS · Atom

cpe:2.3:a:quic-go_project:quic-go:0.40.0:*:*:*:*:*:*:*

part: a version: 0.40.0 update: *

VendorQuic Go Project (1b854078-c907-5eed-aa5d-11522530d114)
ProductQuic Go (41d832e1-00ec-52f7-8887-d14bd7d090e3)
Edition*
Language*
Software edition*
Target software*
Target hardware*
Other*

Notes

Imported from NVD CPE 2.0 feed

PURL mappings

PURLSourceLast updated
pkg:deb/debian/golang-github-lucas-clemente-quic-go purl2cpe 2026-06-01 10:12:44.471675
pkg:deb/ubuntu/golang-github-lucas-clemente-quic-go purl2cpe 2026-06-01 10:12:44.471676
pkg:github/lucas-clemente/quic-go purl2cpe 2026-06-01 10:12:44.471677

Vulnerability references

IdentifiercpeApplicabilitySubmitteddb.gcve.eu detailsRationale
CVE:CVE-2023-49295 vulnerable 2026-06-08 06:14:28.986313 quic-go's path validation mechanism can cause denial of service
MEDIUM (6.4)
quic-go is an implementation of the QUIC protocol (RFC 9000, RFC 9001, RFC 9002) in Go. An attacker can cause its peer to run out of memory sending a large number of PATH_CHALLENGE frames. The receiver is supposed to respond to each PATH_CHALLENGE frame with a PATH_RESPONSE frame. The attacker can prevent the receiver from sending out (the vast majority of) these PATH_RESPONSE frames by collapsing the peers congestion window (by selectively acknowledging received packets) and by manipulating the peer's RTT estimate. This vulnerability has been patched in versions 0.37.7, 0.38.2 and 0.39.4.
Published: 2024-01-10T21:40:58.881Z
Updated: 2025-06-17T20:59:15.978Z
Reference links
Imported from gcve-enriched-dumps CVE data

Contribute

You can submit an edit proposal for this CPE entry or suggest a related product/vendor addition using the action button above.

Inspect record JSON

Open JSON directly

Open this panel to browse, search, copy or download the JSON record.