Approved changes feed: RSS · Atom

cpe:2.3:a:urosevic:stock_ticker:*:*:*:*:*:wordpress:*:*

part: a version: * update: *

VendorUrosevic (aa4c6142-3c0f-5d8c-8625-0e2ecb8e4c5e)
ProductStock Ticker (734b7c70-a49a-534e-b982-e574a64239bb)
Edition*
Language*
Software edition*
Target softwarewordpress
Target hardware*
Other*

Notes

Imported from purl2cpe mapping

PURL mappings

PURLSourceLast updated
pkg:github/urosevic/stock-ticker purl2cpe 2026-06-01 10:11:09.296803

Vulnerability references

IdentifiercpeApplicabilitySubmitteddb.gcve.eu detailsRationale
CVE:CVE-2024-6363 vulnerable 2026-06-08 06:58:18.765776 Stock Ticker <= 3.24.4 - Authenticated (Contributor+) Stored Cross-Site Scripting via stock_ticker Shortcode
MEDIUM (6.4)
The Stock Ticker plugin for WordPress is vulnerable to Stored Cross-Site Scripting via the plugin's stock_ticker shortcode in all versions up to, and including, 3.24.4 due to insufficient input sanitization and output escaping on user supplied attributes. This makes it possible for authenticated attackers, with contributor-level access and above, to inject arbitrary web scripts in pages that will execute whenever a user accesses an injected page.
Published: 2024-06-29T07:05:34.703Z
Updated: 2026-04-08T16:43:00.874Z
Reference links
Imported from gcve-enriched-dumps CVE data
CVE:CVE-2023-51541 vulnerable 2026-06-08 06:17:53.458371 WordPress Stock Ticker Plugin <= 3.23.4 is vulnerable to Cross Site Scripting (XSS)
MEDIUM (6.5)
Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting') vulnerability in Aleksandar Urošević Stock Ticker allows Stored XSS.This issue affects Stock Ticker: from n/a through 3.23.4.
Published: 2023-12-29T10:15:45.369Z
Updated: 2026-04-28T16:09:04.225Z
Reference links
Imported from gcve-enriched-dumps CVE data
CVE:CVE-2023-40208 vulnerable 2026-06-08 06:09:41.451019 WordPress Stock Ticker Plugin <= 3.23.3 is vulnerable to Cross Site Scripting (XSS)
HIGH (7.1)
Unauth. Reflected Cross-Site Scripting (XSS) vulnerability in Aleksandar Urošević Stock Ticker plugin <= 3.23.3 versions.
Published: 2023-09-04T10:40:09.268Z
Updated: 2026-04-28T16:08:36.321Z
Reference links
Imported from gcve-enriched-dumps CVE data
CVE:CVE-2022-45365 vulnerable 2026-06-08 05:50:36.119559 WordPress Stock Ticker Plugin <= 3.23.2 is vulnerable to Cross Site Scripting (XSS)
HIGH (7.1)
Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting') vulnerability in Aleksandar Urošević Stock Ticker allows Reflected XSS.This issue affects Stock Ticker: from n/a through 3.23.2.
Published: 2023-12-14T14:46:03.098Z
Updated: 2026-04-28T16:07:52.511Z
Reference links
Imported from gcve-enriched-dumps CVE data

Contribute

You can submit an edit proposal for this CPE entry or suggest a related product/vendor addition using the action button above.

Inspect record JSON

Open JSON directly

Open this panel to browse, search, copy or download the JSON record.