Approved changes feed: RSS · Atom
cpe:2.3:a:grocy_project:grocy:*:*:*:*:*:*:*:*part: a version: * update: *
| Vendor | Grocy Project (45dd3f2f-5960-58b1-9ff7-b58449ca2a97) |
|---|---|
| Product | Grocy (914ed8ae-c5ec-5f1c-a72f-01437b3c1179) |
| Edition | * |
| Language | * |
| Software edition | * |
| Target software | * |
| Target hardware | * |
| Other | * |
Notes
Imported from purl2cpe mapping
PURL mappings
| PURL | Source | Last updated |
|---|---|---|
pkg:github/grocy/grocy |
purl2cpe | 2026-06-01 10:11:11.720908 |
Vulnerability references
| Identifier | cpeApplicability | Submitted | db.gcve.eu details | Rationale |
|---|---|---|---|---|
CVE:CVE-2024-8370 |
vulnerable | 2026-06-08 07:00:24.393877 |
Grocy SVG File Upload recipepictures cross site scripting
LOW (3.5)
A vulnerability classified as problematic was found in Grocy up to 4.2.0. This vulnerability affects unknown code of the file /api/files/recipepictures/ of the component SVG File Upload Handler. The manipulation of the argument force_serve_as with the input picture' leads to cross site scripting. The attack can be initiated remotely. The exploit has been disclosed to the public and may be used. The real existence of this vulnerability is still doubted at the moment. Unfortunately, the project maintainer does not want to be quoted in any way regarding the dispute rationale. The security policy of the project implies that this finding is "practically irrelevant" due to authentication requirements.
Published: 2024-09-01T22:00:04.021Z
Updated: 2024-09-03T14:23:22.210Z |
Imported from gcve-enriched-dumps CVE data |
CVE:CVE-2024-55076 |
vulnerable | 2026-06-08 06:54:16.929433 |
Details available
HIGH (8.1)
Grocy through 4.3.0 has no CSRF protection, as demonstrated by changing the Administrator's password.
Published: 2025-01-06T00:00:00.000Z
Updated: 2025-01-06T20:48:54.451Z |
Imported from gcve-enriched-dumps CVE data |
CVE:CVE-2024-55075 |
vulnerable | 2026-06-08 06:54:16.929122 |
Details available
MEDIUM (4.3)
Grocy through 4.3.0 allows remote attackers to obtain sensitive information via direct requests to pages that are not shown in the UI, such as calendar and recipes.
Published: 2025-01-06T00:00:00.000Z
Updated: 2025-01-06T21:13:15.565Z |
Imported from gcve-enriched-dumps CVE data |
CVE:CVE-2024-55074 |
vulnerable | 2026-06-08 06:54:16.928611 |
Details available
HIGH (8.8)
The edit profile function of Grocy through 4.3.0 allows stored XSS and resultant privilege escalation by uploading a crafted HTML or SVG file, a different issue than CVE-2024-8370.
Published: 2025-01-06T00:00:00.000Z
Updated: 2025-01-06T20:50:19.099Z |
Imported from gcve-enriched-dumps CVE data |
CVE:CVE-2023-48866 |
vulnerable | 2026-06-08 06:14:28.263774 |
Details available
A Cross-Site Scripting (XSS) vulnerability in the recipe preparation component within /api/objects/recipes and note component within /api/objects/shopping_lists/ of Grocy <= 4.0.3 allows attackers to obtain the victim's cookies.
Published: 2023-12-04T00:00:00.000Z
Updated: 2025-09-29T14:31:00.998Z |
Imported from gcve-enriched-dumps CVE data |
CVE:CVE-2023-42270 |
vulnerable | 2026-06-08 06:11:07.962319 | db.gcve.eu details were skipped to keep the page responsive. | Imported from gcve-enriched-dumps CVE data |
Contribute
You can submit an edit proposal for this CPE entry or suggest a related product/vendor addition using the action button above.
Inspect record JSON
Open this panel to browse, search, copy or download the JSON record.