Point Cloud Library
Approved changes feed: RSS · Atom
cpe:2.3:a:pointclouds:point_cloud_library:*:*:*:*:*:*:*:*part: a version: * update: *
| Vendor | Pointclouds (ee83747d-a3f9-58b0-9d72-058b9aaca4e1) |
|---|---|
| Product | Point Cloud Library (2cc88b6d-3efa-538b-9bd9-9bc7d09491ed) |
| Edition | * |
| Language | * |
| Software edition | * |
| Target software | * |
| Target hardware | * |
| Other | * |
Notes
Imported from purl2cpe mapping
PURL mappings
| PURL | Source | Last updated |
|---|---|---|
pkg:github/pointcloudlibrary/pcl |
purl2cpe | 2026-06-01 10:11:22.795550 |
Vulnerability references
| Identifier | cpeApplicability | Submitted | db.gcve.eu details | Rationale |
|---|---|---|---|---|
CVE:CVE-2025-4638 |
vulnerable | 2026-06-08 07:29:16.780643 |
Improper Pointer Arithmetic in pcl
A vulnerability exists in the inftrees.c component of the zlib library, which is bundled within the PointCloudLibrary (PCL). This issue may allow context-dependent attackers to cause undefined behavior by exploiting improper pointer arithmetic.
Since version 1.14.0, PCL by default uses a zlib installation from the system, unless the user sets WITH_SYSTEM_ZLIB=FALSE. So this potential vulnerability is only relevant if the PCL version is older than 1.14.0 or the user specifically requests to not use the system zlib.
Published: 2025-05-14T17:59:58.180Z
Updated: 2025-05-15T13:49:10.296Z |
Imported from gcve-enriched-dumps CVE data |
Contribute
You can submit an edit proposal for this CPE entry or suggest a related product/vendor addition using the action button above.
Inspect record JSON
Open this panel to browse, search, copy or download the JSON record.