Approved changes feed: RSS · Atom
cpe:2.3:a:ejs:ejs:*:*:*:*:*:*:*:*part: a version: * update: *
| Vendor | Ejs (6e664532-bece-504e-bc12-138f270e6495) |
|---|---|
| Product | Ejs (a08c67d5-799d-552a-8619-bb2180e03f03) |
| Edition | * |
| Language | * |
| Software edition | * |
| Target software | * |
| Target hardware | * |
| Other | * |
Notes
Imported from purl2cpe mapping
PURL mappings
| PURL | Source | Last updated |
|---|---|---|
pkg:github/mde/ejs |
purl2cpe | 2026-06-01 10:11:29.276547 |
pkg:maven/org.webjars.npm/ejs |
purl2cpe | 2026-06-01 10:11:29.276551 |
pkg:npm/ejs |
purl2cpe | 2026-06-01 10:11:29.276553 |
pkg:nuget/EJS |
purl2cpe | 2026-06-01 10:11:29.276556 |
Vulnerability references
| Identifier | cpeApplicability | Submitted | db.gcve.eu details | Rationale |
|---|---|---|---|---|
CVE:CVE-2017-1000228 |
vulnerable | 2026-06-08 05:08:34.293352 |
Details available
nodejs ejs versions older than 2.5.3 is vulnerable to remote code execution due to weak input validation in ejs.renderFile() function
Published: 2017-11-17T03:00:00.000Z
Updated: 2024-08-05T21:53:07.303Z |
Imported from gcve-enriched-dumps CVE data |
CVE:CVE-2017-1000189 |
vulnerable | 2026-06-08 05:08:34.224871 |
Details available
nodejs ejs version older than 2.5.5 is vulnerable to a denial-of-service due to weak input validation in the ejs.renderFile()
Published: 2017-11-17T03:00:00.000Z
Updated: 2024-08-05T21:53:07.124Z |
Imported from gcve-enriched-dumps CVE data |
CVE:CVE-2017-1000188 |
vulnerable | 2026-06-08 05:08:34.224460 |
Details available
nodejs ejs version older than 2.5.5 is vulnerable to a Cross-site-scripting in the ejs.renderFile() resulting in code injection
Published: 2017-11-17T03:00:00.000Z
Updated: 2024-08-05T21:53:07.088Z |
Imported from gcve-enriched-dumps CVE data |
Contribute
You can submit an edit proposal for this CPE entry or suggest a related product/vendor addition using the action button above.
Inspect record JSON
Open this panel to browse, search, copy or download the JSON record.