Wp Latest Posts
Approved changes feed: RSS · Atom
cpe:2.3:a:joomunited:wp_latest_posts:*:*:*:*:*:*:*:*part: a version: * update: *
| Vendor | Joomunited (ac4800e3-8d14-52d4-a07b-f57bf4934a04) |
|---|---|
| Product | Wp Latest Posts (ca00f7af-dace-5cb2-a58e-0b865f56623b) |
| Edition | * |
| Language | * |
| Software edition | * |
| Target software | * |
| Target hardware | * |
| Other | * |
Notes
Imported from purl2cpe mapping
PURL mappings
| PURL | Source | Last updated |
|---|---|---|
pkg:github/wp-plugins/wp-latest-posts |
purl2cpe | 2026-06-01 10:11:30.901818 |
Vulnerability references
| Identifier | cpeApplicability | Submitted | db.gcve.eu details | Rationale |
|---|---|---|---|---|
CVE:CVE-2026-9620 |
vulnerable | 2026-07-29 01:12:09.408036 |
WP Latest Posts <= 5.0.11 - Authenticated (Author+) Stored Cross-Site Scripting via Post Content Image src Attribute
MEDIUM (6.4)
The WP Latest Posts plugin for WordPress is vulnerable to Stored Cross-Site Scripting via crafted image src attributes in post content in versions up to, and including, 5.0.11. This is due to insufficient output escaping in the field() and loop() functions, which extract the raw src attribute value from <img> tags within post_content using a regular expression and then reconstruct new <img> elements or CSS background-image declarations by directly concatenating the unescaped value — bypassing WordPress's kses filtering entirely. This makes it possible for authenticated attackers, with author-level access and above, to inject arbitrary web scripts in pages that will execute whenever a user accesses an injected page.
Published: 2026-06-24T05:33:31.605Z
Updated: 2026-06-25T13:29:01.727Z Reference links
|
Imported from gcve-enriched-dumps CVE data |
CVE:CVE-2024-4135 |
vulnerable | 2026-06-08 06:50:17.081225 |
WP Latest Posts <= 5.0.7 - Authenticated (Subscriber+) Arbitrary Shortcode Execution
MEDIUM (5.4)
The WP Latest Posts plugin for WordPress is vulnerable to arbitrary shortcode execution in all versions up to, and including, 5.0.7. This is due to the plugin allowing users to execute an action that does not properly validate a user-supplied value prior to using that value in a call to do_shortcode. This makes it possible for unauthenticated attackers to execute arbitrary shortcodes.
Published: 2024-05-08T09:31:35.378Z
Updated: 2026-04-08T16:54:28.700Z |
Imported from gcve-enriched-dumps CVE data |
Contribute
You can submit an edit proposal for this CPE entry or suggest a related product/vendor addition using the action button above.
Inspect record JSON
Open this panel to browse, search, copy or download the JSON record.