Openharmony
Approved changes feed: RSS · Atom
cpe:2.3:a:openharmony:openharmony:*:*:*:*:long_term_support:*:*:*part: a version: * update: *
| Vendor | Openharmony (110fda47-4cdc-5732-a162-504663965214) |
|---|---|
| Product | Openharmony (83c4e1d9-4e38-571f-931a-960fef081765) |
| Edition | * |
| Language | * |
| Software edition | long_term_support |
| Target software | * |
| Target hardware | * |
| Other | * |
Notes
Imported from purl2cpe mapping
PURL mappings
| PURL | Source | Last updated |
|---|---|---|
pkg:github/fenwii/openharmony |
purl2cpe | 2026-06-01 10:11:34.393430 |
Vulnerability references
| Identifier | cpeApplicability | Submitted | db.gcve.eu details | Rationale |
|---|---|---|---|---|
CVE:CVE-2024-22092 |
vulnerable | 2026-06-08 06:29:33.647748 |
Bundlemanager has an authentication bypass vulnerability
HIGH (7.7)
in OpenHarmony v3.2.4 and prior versions allow a remote attacker bypass permission verification to install apps, although these require user action.
Published: 2024-04-02T06:22:58.948Z
Updated: 2024-08-01T22:35:34.877Z |
Imported from gcve-enriched-dumps CVE data |
CVE:CVE-2022-41686 |
vulnerable | 2026-06-08 05:48:30.786086 |
Out-of-bound memory read and write in /dev/mmz_userdev device driver. The impact depends on the privileges of the attacker. The unprivileged process run on the device could read out-of-bound memory leading sensitive to information disclosure. The proc ...
MEDIUM (5.1)
OpenHarmony-v3.1.2 and prior versions, 3.0.6 and prior versions have an Out-of-bound memory read and write vulnerability in /dev/mmz_userdev device driver. The impact depends on the privileges of the attacker. The unprivileged process run on the device could read out-of-bound memory leading sensitive to information disclosure. The processes with system user UID run on the device would be able to write out-of-bound memory which could lead to unspecified memory corruption.
Published: 2022-10-14T14:40:04.568Z
Updated: 2025-05-14T15:16:13.328Z |
Imported from gcve-enriched-dumps CVE data |
CVE:CVE-2022-38701 |
vulnerable | 2026-06-08 05:47:16.898890 |
IPC in communication subsystem has a heap overflow vulnerability. Local attackers can trigger a heap overflow and get network sensitive information.
MEDIUM (6.2)
OpenHarmony-v3.1.2 and prior versions have a heap overflow vulnerability. Local attackers can trigger a heap overflow and get network sensitive information.
Published: 2022-09-09T14:39:57.040Z
Updated: 2024-09-16T19:10:47.330Z |
Imported from gcve-enriched-dumps CVE data |
CVE:CVE-2022-36423 |
vulnerable | 2026-06-08 05:46:07.386896 |
Incorrect configuration of the cJSON library lead a Stack overflow vulnerability during recursive parsing. LAN attackers can lead a DoS attack to all network devices.
HIGH (7.4)
OpenHarmony-v3.1.2 and prior versions have an incorrect configuration of the cJSON library, which leads a Stack overflow vulnerability during recursive parsing. LAN attackers can lead a DoS attack to all network devices.
Published: 2022-09-09T14:39:56.347Z
Updated: 2024-09-17T04:03:39.048Z |
Imported from gcve-enriched-dumps CVE data |
Contribute
You can submit an edit proposal for this CPE entry or suggest a related product/vendor addition using the action button above.
Inspect record JSON
Open this panel to browse, search, copy or download the JSON record.