Approved changes feed: RSS · Atom

cpe:2.3:a:bitcoinknots:bitcoin_knots:*:*:*:*:*:*:*:*

part: a version: * update: *

VendorBitcoinknots (c3192a04-70be-53f5-b481-38e15b477984)
ProductBitcoin Knots (bad9fddf-cfcc-599f-9896-43efd7606742)
Edition*
Language*
Software edition*
Target software*
Target hardware*
Other*

Notes

Imported from purl2cpe mapping

PURL mappings

PURLSourceLast updated
pkg:github/bitcoin/bitcoin purl2cpe 2026-06-01 10:12:07.440882
pkg:github/bitcoinknots/bitcoin purl2cpe 2026-06-01 10:12:07.440884

Vulnerability references

IdentifiercpeApplicabilitySubmitteddb.gcve.eu detailsRationale
CVE:CVE-2023-50428 vulnerable 2026-06-08 06:16:16.136173 Details available
In Bitcoin Core through 26.0 and Bitcoin Knots before 25.1.knots20231115, datacarrier size limits can be bypassed by obfuscating data as code (e.g., with OP_FALSE OP_IF), as exploited in the wild by Inscriptions in 2022 and 2023. NOTE: although this is a vulnerability from the perspective of the Bitcoin Knots project, some others consider it "not a bug."
Published: 2023-12-09T00:00:00.000Z
Updated: 2024-08-02T22:16:46.327Z
Reference links
Imported from gcve-enriched-dumps CVE data
CVE:CVE-2018-20587 vulnerable 2026-06-08 05:11:27.600612 Details available
Bitcoin Core 0.12.0 through 0.17.1 and Bitcoin Knots 0.12.0 through 0.17.x before 0.17.1.knots20181229 have Incorrect Access Control. Local users can exploit this to steal currency by binding the RPC IPv4 localhost port, and forwarding requests to the IPv6 localhost port.
Published: 2019-02-11T12:00:00.000Z
Updated: 2024-08-05T12:05:17.687Z
Reference links
Imported from gcve-enriched-dumps CVE data
CVE:CVE-2018-17145 vulnerable 2026-06-08 05:11:05.992734 Details available
Bitcoin Core 0.16.x before 0.16.2 and Bitcoin Knots 0.16.x before 0.16.2 allow remote denial of service via a flood of multiple transaction inv messages with random hashes, aka INVDoS. NOTE: this can also affect other cryptocurrencies, e.g., if they were forked from Bitcoin Core after 2017-11-15.
Published: 2020-09-10T16:32:13.000Z
Updated: 2024-08-05T10:39:59.568Z
Reference links
Imported from gcve-enriched-dumps CVE data
CVE:CVE-2018-17144 vulnerable 2026-06-08 05:11:05.985780 Details available
Bitcoin Core 0.14.x before 0.14.3, 0.15.x before 0.15.2, and 0.16.x before 0.16.3 and Bitcoin Knots 0.14.x through 0.16.x before 0.16.3 allow a remote denial of service (application crash) exploitable by miners via duplicate input. An attacker can make bitcoind or Bitcoin-Qt crash.
Published: 2018-09-19T08:00:00.000Z
Updated: 2024-08-05T10:39:59.599Z
Reference links
Imported from gcve-enriched-dumps CVE data

Contribute

You can submit an edit proposal for this CPE entry or suggest a related product/vendor addition using the action button above.

Inspect record JSON

Open JSON directly

Open this panel to browse, search, copy or download the JSON record.