Json Api User
Approved changes feed: RSS · Atom
cpe:2.3:a:parorrey:json_api_user:*:*:*:*:*:*:*:*part: a version: * update: *
| Vendor | Parorrey (de9b38e5-96b2-5496-b5bf-9d8b29fd4df9) |
|---|---|
| Product | Json Api User (4af6a152-46ab-52ae-817e-7bd4e9b1e77a) |
| Edition | * |
| Language | * |
| Software edition | * |
| Target software | * |
| Target hardware | * |
| Other | * |
Notes
Imported from purl2cpe mapping
PURL mappings
| PURL | Source | Last updated |
|---|---|---|
pkg:github/pimedia/json-api-user |
purl2cpe | 2026-06-01 10:12:16.241491 |
pkg:github/wp-plugins/json-api-user |
purl2cpe | 2026-06-01 10:12:16.241494 |
pkg:github/wpplugins/json-api-user |
purl2cpe | 2026-06-01 10:12:16.241497 |
Vulnerability references
| Identifier | cpeApplicability | Submitted | db.gcve.eu details | Rationale |
|---|---|---|---|---|
CVE:CVE-2026-9626 |
vulnerable | 2026-07-29 01:12:09.410110 |
JSON API User <= 4.1.0 - Authenticated (Subscriber+) Stored Cross-Site Scripting via 'content' Parameter
MEDIUM (6.4)
The JSON API User plugin for WordPress is vulnerable to Stored Cross-Site Scripting via the 'content' parameter of the post_comment API endpoint in versions up to, and including, 4.1.0 This is due to insufficient input sanitization in the post_comment() function, which passes the attacker-controlled comment_content value directly to wp_insert_comment() without applying any HTML sanitization, and additionally allows the caller to set comment_approved=1 to self-approve the comment and bypass moderation. This makes it possible for authenticated attackers, with subscriber-level access and above, to inject arbitrary web scripts in pages that will execute whenever a user accesses an injected page.
Published: 2026-07-03T04:30:19.039Z
Updated: 2026-07-06T16:35:54.457Z Reference links
|
Imported from gcve-enriched-dumps CVE data |
CVE:CVE-2024-6624 |
vulnerable | 2026-06-08 06:58:20.028974 |
JSON API User <= 3.9.3 - Unauthenticated Privilege Escalation
CRITICAL (9.8)
The JSON API User plugin for WordPress is vulnerable to privilege escalation in all versions up to, and including, 3.9.3. This is due to improper controls on custom user meta fields. This makes it possible for unauthenticated attackers to register as administrators on the site. The plugin requires the JSON API plugin to also be installed.
Published: 2024-07-11T06:43:13.276Z
Updated: 2026-04-08T17:13:06.826Z Reference links
|
Imported from gcve-enriched-dumps CVE data |
Contribute
You can submit an edit proposal for this CPE entry or suggest a related product/vendor addition using the action button above.
Inspect record JSON
Open this panel to browse, search, copy or download the JSON record.