Approved changes feed: RSS · Atom
cpe:2.3:a:unix4lyfe:darkhttpd:*:*:*:*:*:*:*:*part: a version: * update: *
| Vendor | Unix4Lyfe (da7aeeae-36e2-5d2f-b416-c9d095f0f25c) |
|---|---|
| Product | Darkhttpd (7fe68e02-e615-51ff-b773-0939f3bf1ca4) |
| Edition | * |
| Language | * |
| Software edition | * |
| Target software | * |
| Target hardware | * |
| Other | * |
Notes
Imported from purl2cpe mapping
PURL mappings
| PURL | Source | Last updated |
|---|---|---|
pkg:github/emikulic/darkhttpd |
purl2cpe | 2026-06-01 10:12:18.057235 |
Vulnerability references
| Identifier | cpeApplicability | Submitted | db.gcve.eu details | Rationale |
|---|---|---|---|---|
CVE:CVE-2024-23771 |
vulnerable | 2026-06-08 06:29:40.422231 |
Details available
darkhttpd before 1.15 uses strcmp (which is not constant time) to verify authentication, which makes it easier for remote attackers to bypass authentication via a timing side channel.
Published: 2024-01-22T00:00:00.000Z
Updated: 2025-05-30T14:23:16.116Z |
Imported from gcve-enriched-dumps CVE data |
CVE:CVE-2024-23770 |
vulnerable | 2026-06-08 06:29:40.421496 |
Details available
darkhttpd through 1.15 allows local users to discover credentials (for --auth) by listing processes and their arguments.
Published: 2024-01-22T00:00:00.000Z
Updated: 2025-05-30T14:23:22.098Z |
Imported from gcve-enriched-dumps CVE data |
CVE:CVE-2020-25691 |
vulnerable | 2026-06-08 05:22:37.213042 |
Details available
A flaw was found in darkhttpd. Invalid error handling allows remote attackers to cause denial-of-service by accessing a file with a large modification date. The highest threat from this vulnerability is to system availability.
Published: 2022-04-01T00:00:00.000Z
Updated: 2024-08-04T15:40:36.586Z Reference links |
Imported from gcve-enriched-dumps CVE data |
Contribute
You can submit an edit proposal for this CPE entry or suggest a related product/vendor addition using the action button above.
Inspect record JSON
Open this panel to browse, search, copy or download the JSON record.