Approved changes feed: RSS · Atom

cpe:2.3:o:raspberrymatic:raspberrymatic:*:*:*:*:*:*:*:*

part: o version: * update: *

VendorRaspberrymatic (6aae5b59-82b0-5ed0-809f-72b29a0fc86a)
ProductRaspberrymatic (b5e9b2aa-4775-5fb8-b036-3c634f49fd44)
Edition*
Language*
Software edition*
Target software*
Target hardware*
Other*

Notes

Imported from purl2cpe mapping

PURL mappings

PURLSourceLast updated
pkg:github/jens-maus/raspberrymatic purl2cpe 2026-06-01 10:12:19.713161

Vulnerability references

IdentifiercpeApplicabilitySubmitteddb.gcve.eu detailsRationale
CVE:CVE-2024-24578 vulnerable 2026-06-08 06:29:41.512208 RaspberryMatic Unauthenticated Remote Code Execution vulnerability through HMServer File Upload
CRITICAL (10)
RaspberryMatic is an open-source operating system for HomeMatic internet-of-things devices. RaspberryMatic / OCCU prior to version 3.75.6.20240316 contains a unauthenticated remote code execution (RCE) vulnerability, caused by multiple issues within the Java based `HMIPServer.jar` component. RaspberryMatric includes a Java based `HMIPServer`, that can be accessed through URLs starting with `/pages/jpages`. The `FirmwareController` class does however not perform any session id checks, thus this feature can be accessed without a valid session. Due to this issue, attackers can gain remote code execution as root user, allowing a full system compromise. Version 3.75.6.20240316 contains a patch.
Published: 2024-03-18T21:13:03.626Z
Updated: 2024-08-26T13:54:04.130Z
Reference links
Imported from gcve-enriched-dumps CVE data
CVE:CVE-2022-24796 vulnerable 2026-06-08 05:41:01.649597 Remote Command Injection in RaspberryMatic
CRITICAL (10)
RaspberryMatic is a free and open-source operating system for running a cloud-free smart-home using the homematicIP / HomeMatic hardware line of IoT devices. A Remote Code Execution (RCE) vulnerability in the file upload facility of the WebUI interface of RaspberryMatic exists. Missing input validation/sanitization in the file upload mechanism allows remote, unauthenticated attackers with network access to the WebUI interface to achieve arbitrary operating system command execution via shell metacharacters in the HTTP query string. Injected commands are executed as root, thus leading to a full compromise of the underlying system and all its components. Versions after `2.31.25.20180428` and prior to `3.63.8.20220330` are affected. Users are advised to update to version `3.63.8.20220330` or newer. There are currently no known workarounds to mitigate the security impact and users are advised to update to the latest version available.
Published: 2022-03-31T22:40:17.000Z
Updated: 2025-04-23T18:42:47.417Z
Reference links
Imported from gcve-enriched-dumps CVE data

Contribute

You can submit an edit proposal for this CPE entry or suggest a related product/vendor addition using the action button above.

Inspect record JSON

Open JSON directly

Open this panel to browse, search, copy or download the JSON record.