Asciidoctor Include Ext
Approved changes feed: RSS · Atom
cpe:2.3:a:asciidoctor-include-ext_project:asciidoctor-include-ext:*:*:*:*:*:*:*:*
part: a version: * update: *
| Vendor | Asciidoctor Include Ext Project (209caea3-d1e0-5124-a52b-df5891a0b170) |
|---|---|
| Product | Asciidoctor Include Ext (8d862307-ee65-5a52-95ed-9225cf95c2df) |
| Edition | * |
| Language | * |
| Software edition | * |
| Target software | * |
| Target hardware | * |
| Other | * |
| Notes | Imported from purl2cpe mapping |
PURL mappings
| PURL | Source | Last updated |
|---|---|---|
pkg:deb/debian/ruby-asciidoctor-include-ext |
purl2cpe | 2026-06-01 10:12:25.615465 |
pkg:deb/ubuntu/astc-encoder |
purl2cpe | 2026-06-01 10:12:25.615469 |
pkg:gem/asciidoctor-include-ext |
purl2cpe | 2026-06-01 10:12:25.615473 |
pkg:github/jirutka/asciidoctor-include-ext |
purl2cpe | 2026-06-01 10:12:25.615476 |
pkg:rpm/opensuse/rubygem-asciidoctor-include-ext |
purl2cpe | 2026-06-01 10:12:25.615480 |
Vulnerability references
| Identifier | cpeApplicability | Submitted | db.gcve.eu details | Rationale |
|---|---|---|---|---|
CVE:CVE-2022-24803 |
vulnerable | 2026-06-08 05:41:01.721300 |
Command Injection vulnerability in asciidoctor-include-ext
CRITICAL (10)
Asciidoctor-include-ext is Asciidoctor’s standard include processor reimplemented as an extension. Versions prior to 0.4.0, when used to render user-supplied input in AsciiDoc markup, may allow an attacker to execute arbitrary system commands on the host operating system. This attack is possible even when `allow-uri-read` is disabled! The problem has been patched in the referenced commits.
Published: 2022-03-31T23:30:14.000Z
Updated: 2025-04-22T18:17:46.997Z Reference links |
Imported from gcve-enriched-dumps CVE data |
Contribute
You can submit an edit proposal for this CPE entry or suggest a related product/vendor addition using the action button above.