Approved changes feed: RSS · Atom

cpe:2.3:a:lldpd_project:lldpd:*:*:*:*:*:*:*:*

part: a version: * update: *

VendorLldpd Project (8eb0be01-8c7d-5434-a17c-4652414bc9c4)
ProductLldpd (c848b8f3-6e35-5e57-b20e-c1938f48a540)
Edition*
Language*
Software edition*
Target software*
Target hardware*
Other*

Notes

Imported from purl2cpe mapping

PURL mappings

PURLSourceLast updated
pkg:deb/debian/lldpd purl2cpe 2026-06-01 10:12:33.760484
pkg:deb/ubuntu/lldpd purl2cpe 2026-06-01 10:12:33.760487
pkg:github/lldpd/lldpd purl2cpe 2026-06-01 10:12:33.760490
pkg:rpm/centos/lldpd purl2cpe 2026-06-01 10:12:33.760493
pkg:rpm/fedora/lldpd purl2cpe 2026-06-01 10:12:33.760495
pkg:rpm/opensuse/lldpd purl2cpe 2026-06-01 10:12:33.760498

Vulnerability references

IdentifiercpeApplicabilitySubmitteddb.gcve.eu detailsRationale
CVE:CVE-2023-41910 vulnerable 2026-06-08 06:11:07.408893 Details available
An issue was discovered in lldpd before 1.0.17. By crafting a CDP PDU packet with specific CDP_TLV_ADDRESSES TLVs, a malicious actor can remotely force the lldpd daemon to perform an out-of-bounds read on heap memory. This occurs in cdp_decode in daemon/protocols/cdp.c.
Published: 2023-09-05T00:00:00.000Z
Updated: 2024-09-30T17:18:00.941Z
Reference links
Imported from gcve-enriched-dumps CVE data
CVE:CVE-2021-43612 vulnerable 2026-06-08 05:36:43.621005 Details available
In lldpd before 1.0.13, when decoding SONMP packets in the sonmp_decode function, it's possible to trigger an out-of-bounds heap read via short SONMP packets.
Published: 2023-04-15T00:00:00.000Z
Updated: 2025-02-13T16:28:43.689Z
Reference links
Imported from gcve-enriched-dumps CVE data
CVE:CVE-2020-27827 vulnerable 2026-06-08 05:23:53.261656 Details available
A flaw was found in multiple versions of OpenvSwitch. Specially crafted LLDP packets can cause memory to be lost when allocating data to handle specific optional TLVs, potentially causing a denial of service. The highest threat from this vulnerability is to system availability.
Published: 2021-03-18T00:00:00.000Z
Updated: 2025-12-03T18:20:03.875Z
Reference links
Imported from gcve-enriched-dumps CVE data
CVE:CVE-2015-8012 vulnerable 2026-06-08 05:07:02.868493 Details available
lldpd before 0.8.0 allows remote attackers to cause a denial of service (assertion failure and daemon crash) via a malformed packet.
Published: 2020-01-28T18:15:04.000Z
Updated: 2024-08-06T08:06:31.773Z
Reference links
Imported from gcve-enriched-dumps CVE data
CVE:CVE-2015-8011 vulnerable 2026-06-08 05:07:02.866305 Details available
Buffer overflow in the lldp_decode function in daemon/protocols/lldp.c in lldpd before 0.8.0 allows remote attackers to cause a denial of service (daemon crash) and possibly execute arbitrary code via vectors involving large management addresses and TLV boundaries.
Published: 2020-01-28T18:15:08.000Z
Updated: 2024-08-06T08:06:31.689Z
Reference links
Imported from gcve-enriched-dumps CVE data

Contribute

You can submit an edit proposal for this CPE entry or suggest a related product/vendor addition using the action button above.

Inspect record JSON

Open JSON directly

Open this panel to browse, search, copy or download the JSON record.