Approved changes feed: RSS · Atom

cpe:2.3:a:xpressengine:xpressengine:*:*:*:*:*:*:*:*

part: a version: * update: *

VendorXpressengine (bab1327a-e835-58bc-9c23-4bb0b94dd7c8)
ProductXpressengine (36e0f195-78cd-5cad-ba34-65949c7dc5cd)
Edition*
Language*
Software edition*
Target software*
Target hardware*
Other*

Notes

Imported from purl2cpe mapping

PURL mappings

PURLSourceLast updated
pkg:github/xpressengine/xe-core purl2cpe 2026-06-01 10:12:34.273581

Vulnerability references

IdentifiercpeApplicabilitySubmitteddb.gcve.eu detailsRationale
CVE:CVE-2021-44912 vulnerable 2026-06-08 05:36:47.620033 Details available
In XE 1.116, when uploading the Normal button, there is no restriction on the file suffix, which leads to any file uploading to the files directory. Since .htaccess only restricts the PHP type, uploading HTML-type files leads to stored XSS vulnerabilities. If the .htaccess configuration is improper, for example before the XE 1.11.2 version, you can upload the PHP type file to GETSHELL.
Published: 2022-02-09T15:55:05.000Z
Updated: 2024-08-04T04:32:13.216Z
Reference links
Imported from gcve-enriched-dumps CVE data
CVE:CVE-2021-44911 vulnerable 2026-06-08 05:36:47.619518 Details available
XE before 1.11.6 is vulnerable to Unrestricted file upload via modules/menu/menu.admin.controller.php. When uploading the Mouse over button and When selected button, there is no restriction on the file suffix, which leads to any file uploading to the files directory. Since .htaccess only restricts the PHP type, uploading HTML-type files leads to stored XSS vulnerabilities.
Published: 2022-02-09T15:40:49.000Z
Updated: 2024-08-04T04:32:13.235Z
Reference links
Imported from gcve-enriched-dumps CVE data
CVE:CVE-2021-26642 vulnerable 2026-06-08 05:30:45.032863 XpressEngine file upload vulnerability
HIGH (8.8)
When uploading an image file to a bulletin board developed with XpressEngine, a vulnerability in which an arbitrary file can be uploaded due to insufficient verification of the file. A remote attacker can use this vulnerability to execute arbitrary code on the server where the bulletin board is running.
Published: 2023-01-20T00:00:00.000Z
Updated: 2025-04-03T16:59:58.376Z
Reference links
Imported from gcve-enriched-dumps CVE data
CVE:CVE-2011-10003 vulnerable 2026-06-08 04:56:40.568898 XpressEngine Update Query sql injection
MEDIUM (5.5)
A vulnerability was found in XpressEngine up to 1.4.4. It has been rated as critical. This issue affects some unknown processing of the component Update Query Handler. The manipulation leads to sql injection. Upgrading to version 1.4.5 is able to address this issue. The patch is named c6e94449f21256d6362450b29c7847305e756ad5. It is recommended to upgrade the affected component. The associated identifier of this vulnerability is VDB-220247.
Published: 2023-02-07T21:00:04.107Z
Updated: 2025-03-25T15:44:24.444Z
Reference links
Imported from gcve-enriched-dumps CVE data

Contribute

You can submit an edit proposal for this CPE entry or suggest a related product/vendor addition using the action button above.

Inspect record JSON

Open JSON directly

Open this panel to browse, search, copy or download the JSON record.