Approved changes feed: RSS · Atom

cpe:2.3:a:speedtech:storm:6.x-1.4:*:*:*:*:*:*:*

part: a version: 6.x-1.4 update: *

VendorSpeedtech (a5e10b64-020c-5f8a-86f7-a9bb9e59593f)
ProductStorm (fe5e314d-8adf-5a6c-89f4-2310bd799d6a)
Edition*
Language*
Software edition*
Target software*
Target hardware*
Other*

Notes

Imported from purl2cpe mapping

PURL mappings

PURLSourceLast updated
pkg:github/nathanmarz/storm purl2cpe 2026-06-01 10:12:38.666575

Vulnerability references

IdentifiercpeApplicabilitySubmitteddb.gcve.eu detailsRationale
CVE:CVE-2010-2158 vulnerable 2026-06-08 04:54:11.822693 Details available
Multiple cross-site scripting (XSS) vulnerabilities in the Storm module 5.x and 6.x before 6.x-1.33 for Drupal allow remote authenticated users, with certain module privileges, to inject arbitrary web script or HTML via the (1) fullname, (2) phone, or (3) im parameter in a stormperson action to index.php. NOTE: the provenance of this information is unknown; the details are obtained solely from third party information.
Published: 2010-06-07T14:00:00.000Z
Updated: 2024-09-16T19:31:46.212Z
Reference links
Imported from gcve-enriched-dumps CVE data
CVE:CVE-2010-2123 vulnerable 2026-06-08 04:54:11.708893 Details available
Multiple cross-site scripting (XSS) vulnerabilities in the Storm module 5.x and 6.x before 6.x-1.33 for Drupal allow remote authenticated users, with certain module privileges, to inject arbitrary web script or HTML via the (1) fullname, (2) address, (3) city, (4) provstate (aka state), (5) phone, or (6) taxid parameter in a stormorganization action to index.php; the (7) name parameter in a stormperson action to index.php; the (8) stepno (aka Step no.) or (9) title parameter in a stormtask action to index.php; the (10) title (aka Project) parameter in a stormticket action to index.php; or (11) unspecified parameters in a stormproject action to index.php. NOTE: some of these details are obtained from third party information.
Published: 2010-06-01T21:00:00.000Z
Updated: 2024-08-07T02:25:06.337Z
Reference links
Imported from gcve-enriched-dumps CVE data
CVE:CVE-2009-4515 vulnerable 2026-06-08 04:51:48.709900 Details available
The Storm module 6.x before 6.x-1.25 for Drupal does not enforce privilege requirements for storminvoiceitem nodes, which allows remote attackers to read node titles via unspecified vectors.
Published: 2009-12-31T19:00:00.000Z
Updated: 2024-09-17T03:22:46.291Z
Reference links
Imported from gcve-enriched-dumps CVE data

Contribute

You can submit an edit proposal for this CPE entry or suggest a related product/vendor addition using the action button above.

Inspect record JSON

Open JSON directly

Open this panel to browse, search, copy or download the JSON record.