Approved changes feed: RSS · Atom
cpe:2.3:a:quic-go_project:quic-go:*:*:*:*:*:*:*:*part: a version: * update: *
| Vendor | Quic Go Project (1b854078-c907-5eed-aa5d-11522530d114) |
|---|---|
| Product | Quic Go (41d832e1-00ec-52f7-8887-d14bd7d090e3) |
| Edition | * |
| Language | * |
| Software edition | * |
| Target software | * |
| Target hardware | * |
| Other | * |
Notes
Imported from purl2cpe mapping
PURL mappings
| PURL | Source | Last updated |
|---|---|---|
pkg:deb/debian/golang-github-lucas-clemente-quic-go |
purl2cpe | 2026-06-01 10:12:44.471304 |
pkg:deb/ubuntu/golang-github-lucas-clemente-quic-go |
purl2cpe | 2026-06-01 10:12:44.471306 |
pkg:github/lucas-clemente/quic-go |
purl2cpe | 2026-06-01 10:12:44.471307 |
Vulnerability references
| Identifier | cpeApplicability | Submitted | db.gcve.eu details | Rationale |
|---|---|---|---|---|
CVE:CVE-2025-64702 |
vulnerable | 2026-06-08 07:39:20.173465 |
quic-go HTTP/3 QPACK Header Expansion DoS
MEDIUM (5.3)
quic-go is an implementation of the QUIC protocol in Go. Versions 0.56.0 and below are vulnerable to excessive memory allocation through quic-go's HTTP/3 client and server implementations by sending a QPACK-encoded HEADERS frame that decodes into a large header field section (many unique header names and/or large values). The implementation builds an http.Header (used on the http.Request and http.Response, respectively), while only enforcing limits on the size of the (QPACK-compressed) HEADERS frame, but not on the decoded header, leading to memory exhaustion. This issue is fixed in version 0.57.0.
Published: 2025-12-11T20:58:10.517Z
Updated: 2025-12-12T20:45:30.439Z |
Imported from gcve-enriched-dumps CVE data |
CVE:CVE-2024-22189 |
vulnerable | 2026-06-08 06:29:34.058072 |
QUIC's Connection ID Mechanism vulnerable to Memory Exhaustion Attack
HIGH (7.5)
quic-go is an implementation of the QUIC protocol in Go. Prior to version 0.42.0, an attacker can cause its peer to run out of memory sending a large number of `NEW_CONNECTION_ID` frames that retire old connection IDs. The receiver is supposed to respond to each retirement frame with a `RETIRE_CONNECTION_ID` frame. The attacker can prevent the receiver from sending out (the vast majority of) these `RETIRE_CONNECTION_ID` frames by collapsing the peers congestion window (by selectively acknowledging received packets) and by manipulating the peer's RTT estimate. Version 0.42.0 contains a patch for the issue. No known workarounds are available.
Published: 2024-04-04T14:25:43.663Z
Updated: 2024-08-23T19:29:41.592Z Reference links |
Imported from gcve-enriched-dumps CVE data |
CVE:CVE-2023-49295 |
vulnerable | 2026-06-08 06:14:28.985476 |
quic-go's path validation mechanism can cause denial of service
MEDIUM (6.4)
quic-go is an implementation of the QUIC protocol (RFC 9000, RFC 9001, RFC 9002) in Go. An attacker can cause its peer to run out of memory sending a large number of PATH_CHALLENGE frames. The receiver is supposed to respond to each PATH_CHALLENGE frame with a PATH_RESPONSE frame. The attacker can prevent the receiver from sending out (the vast majority of) these PATH_RESPONSE frames by collapsing the peers congestion window (by selectively acknowledging received packets) and by manipulating the peer's RTT estimate. This vulnerability has been patched in versions 0.37.7, 0.38.2 and 0.39.4.
Published: 2024-01-10T21:40:58.881Z
Updated: 2025-06-17T20:59:15.978Z Reference links
|
Imported from gcve-enriched-dumps CVE data |
CVE:CVE-2023-46239 |
vulnerable | 2026-06-08 06:12:44.462896 |
quic-go vulnerable to pointer dereference that can lead to panic
HIGH (7.5)
quic-go is an implementation of the QUIC protocol in Go. Starting in version 0.37.0 and prior to version 0.37.3, by serializing an ACK frame after the CRYTPO that allows a node to complete the handshake, a remote node could trigger a nil pointer dereference (leading to a panic) when the node attempted to drop the Handshake packet number space. An attacker can bring down a quic-go node with very minimal effort. Completing the QUIC handshake only requires sending and receiving a few packets. Version 0.37.3 contains a patch. Versions before 0.37.0 are not affected.
Published: 2023-10-31T15:02:03.413Z
Updated: 2024-09-05T17:37:20.453Z |
Imported from gcve-enriched-dumps CVE data |
CVE:CVE-2022-30591 |
vulnerable | 2026-06-08 05:43:38.613336 |
Details available
quic-go through 0.27.0 allows remote attackers to cause a denial of service (CPU consumption) via a Slowloris variant in which incomplete QUIC or HTTP/3 requests are sent. This occurs because mtu_discoverer.go misparses the MTU Discovery service and consequently overflows the probe timer. NOTE: the vendor's position is that this behavior should not be listed as a vulnerability on the CVE List
Published: 2022-07-06T11:19:21.000Z
Updated: 2024-08-03T06:56:12.808Z |
Imported from gcve-enriched-dumps CVE data |
Contribute
You can submit an edit proposal for this CPE entry or suggest a related product/vendor addition using the action button above.
Inspect record JSON
Open this panel to browse, search, copy or download the JSON record.