Approved changes feed: RSS · Atom

cpe:2.3:a:benjaminzekavica:easy_svg_support:*:*:*:*:*:wordpress:*:*

part: a version: * update: *

VendorBenjaminzekavica (ed4bbdbf-2cf5-5f23-a750-b31036a435a9)
ProductEasy Svg Support (f41fe1e3-764b-511a-9fb1-45378ecca053)
Edition*
Language*
Software edition*
Target softwarewordpress
Target hardware*
Other*

Notes

Imported from purl2cpe mapping

PURL mappings

PURLSourceLast updated
pkg:github/bz-projects/easy-svg purl2cpe 2026-06-01 10:12:46.477448

Vulnerability references

IdentifiercpeApplicabilitySubmitteddb.gcve.eu detailsRationale
CVE:CVE-2024-10269 vulnerable 2026-06-08 06:22:03.884709 Easy SVG Support <= 3.7 - Authenticated (Author+) Stored Cross-Site Scripting via SVG File Upload
MEDIUM (6.4)
The Easy SVG Support plugin for WordPress is vulnerable to Stored Cross-Site Scripting via REST API SVG File uploads in all versions up to, and including, 3.7 due to insufficient input sanitization and output escaping. This makes it possible for authenticated attackers, with Author-level access and above, to inject arbitrary web scripts in pages that will execute whenever a user accesses the SVG file.
Published: 2024-11-08T06:39:59.186Z
Updated: 2026-04-08T16:56:26.866Z
Reference links
Imported from gcve-enriched-dumps CVE data
CVE:CVE-2023-7089 vulnerable 2026-06-08 06:21:56.999955 Easy SVG Allow <= 1.0 - Author+ Stored XSS via SVG
The Easy SVG Allow WordPress plugin through 1.0 does not sanitize uploaded SVG files, which could allow users with a role as low as Author to upload a malicious SVG containing XSS payloads.
Published: 2024-01-29T14:44:24.539Z
Updated: 2025-06-20T19:44:48.459Z
Reference links
Imported from gcve-enriched-dumps CVE data

Contribute

You can submit an edit proposal for this CPE entry or suggest a related product/vendor addition using the action button above.

Inspect record JSON

Open JSON directly

Open this panel to browse, search, copy or download the JSON record.