Approved changes feed: RSS · Atom

cpe:2.3:a:benjaminrojas:wp_editor:*:*:*:*:*:*:*:*

part: a version: * update: *

VendorBenjaminrojas (6bc69e4e-b467-55a7-897e-34eb1dcb8201)
ProductWp Editor (37d204db-ab28-5d15-aba3-ede21b24672f)
Edition*
Language*
Software edition*
Target software*
Target hardware*
Other*

Notes

Imported from purl2cpe mapping

PURL mappings

PURLSourceLast updated
pkg:github/wp-plugins/wp-editor purl2cpe 2026-06-01 10:12:51.000238

Vulnerability references

IdentifiercpeApplicabilitySubmitteddb.gcve.eu detailsRationale
CVE:CVE-2022-2446 vulnerable 2026-06-08 05:43:35.570530 WP Editor <= 1.2.9 - Authenticated (Admin+) PHAR Deserialization
HIGH (7.2)
The WP Editor plugin for WordPress is vulnerable to deserialization of untrusted input via the 'current_theme_root' parameter in versions up to, and including 1.2.9. This makes it possible for authenticated attackers with administrative privileges to call files using a PHAR wrapper that will deserialize and call arbitrary PHP Objects that can be used to perform a variety of malicious actions granted a POP chain is also present. It also requires that the attacker is successful in uploading a file with the serialized payload.
Published: 2024-09-13T15:10:43.938Z
Updated: 2026-04-08T17:32:49.427Z
Reference links
Imported from gcve-enriched-dumps CVE data

Contribute

You can submit an edit proposal for this CPE entry or suggest a related product/vendor addition using the action button above.

Inspect record JSON

Open JSON directly

Open this panel to browse, search, copy or download the JSON record.