Approved changes feed: RSS · Atom

cpe:2.3:a:smalruby:smalruby-editor:*:*:*:*:*:*:*:*

part: a version: * update: *

VendorSmalruby (d65ccc56-a59b-527f-9df4-99c5a3ad9988)
ProductSmalruby Editor (e17a2c20-9ba9-51ba-b6ff-a47caea2aef8)
Edition*
Language*
Software edition*
Target software*
Target hardware*
Other*

Notes

Imported from purl2cpe mapping

PURL mappings

PURLSourceLast updated
pkg:gem/smalruby-editor purl2cpe 2026-06-01 10:13:09.341301
pkg:github/smalruby/smalruby-editor purl2cpe 2026-06-01 10:13:09.341304

Vulnerability references

IdentifiercpeApplicabilitySubmitteddb.gcve.eu detailsRationale
CVE:CVE-2017-2096 vulnerable 2026-06-08 05:09:23.571555 Details available
smalruby-editor v0.4.0 and earlier allows remote attackers to execute arbitrary OS commands via unspecified vectors.
Published: 2017-04-28T16:00:00.000Z
Updated: 2024-08-05T13:39:32.293Z
Reference links
Imported from gcve-enriched-dumps CVE data

Contribute

You can submit an edit proposal for this CPE entry or suggest a related product/vendor addition using the action button above.

Inspect record JSON

Open JSON directly

Open this panel to browse, search, copy or download the JSON record.