Approved changes feed: RSS · Atom

cpe:2.3:a:booking-wp-plugin:bookly:*:*:*:*:*:wordpress:*:*

part: a version: * update: *

VendorBooking Wp Plugin (7aee1c98-c0b4-5bc5-a984-9bdcb49612b6)
ProductBookly (253b3a88-45d1-5b5c-9d88-ac61375ce6b1)
Edition*
Language*
Software edition*
Target softwarewordpress
Target hardware*
Other*

Notes

Imported from purl2cpe mapping

PURL mappings

PURLSourceLast updated
pkg:github/stancel/bookly-responsive-appointment-booking-tool purl2cpe 2026-06-01 10:13:10.536730
pkg:github/wpplugins/bookly-responsive-appointment-booking-tool purl2cpe 2026-06-01 10:13:10.536732

Vulnerability references

IdentifiercpeApplicabilitySubmitteddb.gcve.eu detailsRationale
CVE:CVE-2023-5209 vulnerable 2026-06-08 06:19:42.880438 Bookly < 22.5 - Admin+ Stored XSS
The WordPress Online Booking and Scheduling Plugin WordPress plugin before 22.5 does not sanitise and escape some of its settings, which could allow high privilege users such as admin to perform Stored Cross-Site Scripting attacks even when the unfiltered_html capability is disallowed (for example in multisite setup)
Published: 2023-11-27T16:21:59.004Z
Updated: 2024-08-02T07:52:07.824Z
Reference links
Imported from gcve-enriched-dumps CVE data
CVE:CVE-2023-4691 vulnerable 2026-06-08 06:16:14.158267 Bookly < 22.4 - Admin+ SQLi
The WordPress Online Booking and Scheduling Plugin WordPress plugin before 22.4 does not properly sanitise and escape a parameter before using it in a SQL statement, leading to a SQL injection exploitable by high privilege users such as admin
Published: 2023-10-16T19:39:05.138Z
Updated: 2025-04-23T16:12:57.035Z
Reference links
Imported from gcve-enriched-dumps CVE data
CVE:CVE-2023-1172 vulnerable 2026-06-08 05:52:34.035492 Details available
HIGH (7.2)
The Bookly plugin for WordPress is vulnerable to Stored Cross-Site Scripting via the full name value in versions up to, and including, 21.5 due to insufficient input sanitization and output escaping. This makes it possible for unauthenticated attackers to inject arbitrary web scripts in pages that will execute whenever a user accesses an injected page.
Published: 2023-03-17T12:20:30.748Z
Updated: 2025-01-13T16:57:36.802Z
Reference links
Imported from gcve-enriched-dumps CVE data
CVE:CVE-2023-1159 vulnerable 2026-06-08 05:52:34.001865 Details available
MEDIUM (4)
The Bookly plugin for WordPress is vulnerable to Stored Cross-Site Scripting via service titles in versions up to, and including, 21.5 due to insufficient input sanitization and output escaping. This makes it possible for authenticated attackers with administrative privileges to inject arbitrary web scripts in pages that will execute whenever a user accesses an injected page. This only affects multi-site installations and installations where unfiltered_html has been disabled.
Published: 2023-06-02T06:06:48.397Z
Updated: 2024-12-20T23:59:57.483Z
Reference links
Imported from gcve-enriched-dumps CVE data
CVE:CVE-2021-24930 vulnerable 2026-06-08 05:30:39.640171 Bookly < 20.3.1 - Staff Member Stored Cross-Site Scripting
The WordPress Online Booking and Scheduling Plugin WordPress plugin before 20.3.1 does not escape the Staff Full Name field before outputting it back in a page, which could lead to a Stored Cross-Site Scripting issue
Published: 2021-12-06T15:55:32.000Z
Updated: 2024-08-03T19:49:14.020Z
Reference links
Imported from gcve-enriched-dumps CVE data
CVE:CVE-2018-6891 vulnerable 2026-06-08 05:11:54.379379 db.gcve.eu details were skipped to keep the page responsive. Imported from gcve-enriched-dumps CVE data

Contribute

You can submit an edit proposal for this CPE entry or suggest a related product/vendor addition using the action button above.

Inspect record JSON

Open JSON directly

Open this panel to browse, search, copy or download the JSON record.