Approved changes feed: RSS · Atom

cpe:2.3:a:asgaros:asgaros_forum:*:*:*:*:*:*:*:*

part: a version: * update: *

VendorAsgaros (5ef36091-679c-506b-8af9-cdb3840b2d50)
ProductAsgaros Forum (a2cb7fb2-118a-5f6d-8550-07cd6da89dd3)
Edition*
Language*
Software edition*
Target software*
Target hardware*
Other*
NotesImported from purl2cpe mapping

PURL mappings

PURLSourceLast updated
pkg:github/asgaros/asgaros-forum purl2cpe 2026-06-01 10:13:18.951806

Vulnerability references

IdentifiercpeApplicabilitySubmitteddb.gcve.eu detailsRationale
CVE:CVE-2025-39514 vulnerable 2026-06-08 07:23:06.686498 WordPress Asgaros Forum plugin <= 3.2.1 - Cross Site Scripting (XSS) vulnerability
MEDIUM (6.5)
Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting') vulnerability in Asgaros Asgaros Forum asgaros-forum allows Stored XSS.This issue affects Asgaros Forum: from n/a through <= 3.2.1.
Published: 2025-04-16T12:45:53.284Z
Updated: 2026-04-28T16:12:33.875Z
Reference links
Imported from gcve-enriched-dumps CVE data
CVE:CVE-2025-32227 vulnerable 2026-06-08 07:18:59.332428 WordPress Asgaros Forum plugin <= 3.0.0 - File Upload Numbers Bypass vulnerability
MEDIUM (4.3)
Authentication Bypass by Spoofing vulnerability in Asgaros Asgaros Forum asgaros-forum allows Identity Spoofing.This issue affects Asgaros Forum: from n/a through <= 3.0.0.
Published: 2025-04-10T08:09:46.011Z
Updated: 2026-04-29T09:51:54.969Z
Reference links
Imported from gcve-enriched-dumps CVE data
CVE:CVE-2025-12901 vulnerable 2026-06-08 07:04:31.170046 Asgaros Forum <= 3.2.1 - Cross-Site Request Forgery to Subscription Settings Update
MEDIUM (4.3)
The Asgaros Forum plugin for WordPress is vulnerable to Cross-Site Request Forgery in all versions up to, and including, 3.2.1. This is due to missing nonce validation on the set_subscription_level() function. This makes it possible for unauthenticated attackers to modify the subscription settings of authenticated users via a forged request granted they can trick a logged-in user into performing an action such as clicking on a link.
Published: 2025-11-12T04:29:09.846Z
Updated: 2026-04-08T17:01:20.293Z
Reference links
Imported from gcve-enriched-dumps CVE data
CVE:CVE-2025-11452 vulnerable 2026-06-08 07:04:28.149346 Asgaros Forum <= 3.1.0 - Unauthenticated SQL Injection
HIGH (7.5)
The Asgaros Forum plugin for WordPress is vulnerable to SQL Injection via the '$_COOKIE['asgarosforum_unread_exclude']' cookie in all versions up to, and including, 3.1.0 due to insufficient escaping on the user supplied parameter and lack of sufficient preparation on the existing SQL query. This makes it possible for unauthenticated attackers to append additional SQL queries into already existing queries that can be used to extract sensitive information from the database.
Published: 2025-11-08T02:28:01.507Z
Updated: 2026-04-08T17:01:24.061Z
Reference links
Imported from gcve-enriched-dumps CVE data

Contribute

You can submit an edit proposal for this CPE entry or suggest a related product/vendor addition using the action button above.