Approved changes feed: RSS · Atom

cpe:2.3:a:asgaros:asgaros_forum:*:*:*:*:*:wordpress:*:*

part: a version: * update: *

VendorAsgaros (5ef36091-679c-506b-8af9-cdb3840b2d50)
ProductAsgaros Forum (a2cb7fb2-118a-5f6d-8550-07cd6da89dd3)
Edition*
Language*
Software edition*
Target softwarewordpress
Target hardware*
Other*
NotesImported from purl2cpe mapping

PURL mappings

PURLSourceLast updated
pkg:github/asgaros/asgaros-forum purl2cpe 2026-06-01 10:13:18.973277

Vulnerability references

IdentifiercpeApplicabilitySubmitteddb.gcve.eu detailsRationale
CVE:CVE-2024-32440 vulnerable 2026-06-08 06:35:33.128420 WordPress Asgaros Forum plugin <= 2.8.0 - Cross Site Request Forgery (CSRF) vulnerability
MEDIUM (4.3)
Cross-Site Request Forgery (CSRF) vulnerability in Thomas Belser Asgaros Forum.This issue affects Asgaros Forum: from n/a through 2.8.0.
Published: 2024-04-15T08:04:18.808Z
Updated: 2026-04-28T16:09:35.400Z
Reference links
Imported from gcve-enriched-dumps CVE data
CVE:CVE-2024-22284 vulnerable 2026-06-08 06:29:34.426625 WordPress Asgaros Forum Plugin <= 2.7.2 is vulnerable to PHP Object Injection
HIGH (8.7)
Deserialization of Untrusted Data vulnerability in Thomas Belser Asgaros Forum.This issue affects Asgaros Forum: from n/a through 2.7.2.
Published: 2024-01-24T11:45:18.150Z
Updated: 2026-04-28T16:09:09.329Z
Reference links
Imported from gcve-enriched-dumps CVE data
CVE:CVE-2023-5604 vulnerable 2026-06-08 06:19:44.136812 Asgaros Forum < 2.7.1 - Unauthenticated Arbitrary File Upload
The Asgaros Forum WordPress plugin before 2.7.1 allows forum administrators, who may not be WordPress (super-)administrators, to set insecure configuration that allows unauthenticated users to upload dangerous files (e.g. .php, .phtml), potentially leading to remote code execution.
Published: 2023-11-27T16:22:00.940Z
Updated: 2025-06-05T14:03:11.558Z
Reference links
Imported from gcve-enriched-dumps CVE data
CVE:CVE-2022-41608 vulnerable 2026-06-08 05:48:30.604647 WordPress Asgaros Forum Plugin <= 2.2.0 is vulnerable to Cross Site Request Forgery (CSRF)
MEDIUM (5.4)
Cross-Site Request Forgery (CSRF) vulnerability in Thomas Belser Asgaros Forum plugin <= 2.2.0 versions.
Published: 2023-05-22T09:55:57.103Z
Updated: 2026-04-28T16:07:49.220Z
Reference links
Imported from gcve-enriched-dumps CVE data
CVE:CVE-2022-0411 vulnerable 2026-06-08 05:39:09.991724 Asgaros Forum < 2.0.0 - Subscriber+ Blind SQL Injection
The Asgaros Forum WordPress plugin before 2.0.0 does not sanitise and escape the post_id parameter before using it in a SQL statement via a REST route of the plugin (accessible to any authenticated user), leading to a SQL injection
Published: 2022-02-28T09:06:54.000Z
Updated: 2024-08-02T23:25:40.440Z
Reference links
Imported from gcve-enriched-dumps CVE data
CVE:CVE-2021-42365 vulnerable 2026-06-08 05:35:22.224610 db.gcve.eu details were skipped to keep the page responsive. Imported from gcve-enriched-dumps CVE data
CVE:CVE-2021-25045 vulnerable 2026-06-08 05:30:39.858499 db.gcve.eu details were skipped to keep the page responsive. Imported from gcve-enriched-dumps CVE data
CVE:CVE-2021-24827 vulnerable 2026-06-08 05:30:39.312143 db.gcve.eu details were skipped to keep the page responsive. Imported from gcve-enriched-dumps CVE data

Contribute

You can submit an edit proposal for this CPE entry or suggest a related product/vendor addition using the action button above.