Approved changes feed: RSS · Atom

cpe:2.3:a:aptrs:aptrs:*:*:*:*:*:*:*:*

part: a version: * update: *

VendorAptrs (a19fe877-cebf-5093-9e4a-4f52d1ab804c)
ProductAptrs (7ac68689-a0a7-588e-bfe0-84fa6107f3e1)
Edition*
Language*
Software edition*
Target software*
Target hardware*
Other*
NotesImported from purl2cpe mapping

PURL mappings

PURLSourceLast updated
pkg:github/aptrs/aptrs purl2cpe 2026-06-01 10:13:25.733718

Vulnerability references

IdentifiercpeApplicabilitySubmitteddb.gcve.eu detailsRationale
CVE:CVE-2026-34406 vulnerable 2026-06-08 07:59:12.486950 APTRS: Privilege Escalation via Mass Assignment of is_superuser in User Edit Endpoint
APTRS (Automated Penetration Testing Reporting System) is a Python and Django-based automated reporting tool designed for penetration testers and security organizations. Prior to version 2.0.1, the edit_user endpoint (POST /api/auth/edituser/<pk>) allows Any user who can reach that endpoint and submit crafted permission to escalate their own account (or any other account) to superuser by including "is_superuser": true in the request body. The root cause is that CustomUserSerializer explicitly includes is_superuser in its fields list but omits it from read_only_fields, making it a writable field. The edit_user view performs no additional validation to prevent non-superusers from modifying this field. Once is_superuser is set to true, gaining unrestricted access to all application functionality without requiring re-authentication. This issue has been patched in version 2.0.1.
Published: 2026-03-31T21:18:51.205Z
Updated: 2026-04-03T16:38:03.750Z
Reference links
Imported from gcve-enriched-dumps CVE data
CVE:CVE-2024-56363 vulnerable 2026-06-08 06:54:17.782995 APTRS has SSTI vulnerability
HIGH (7.8)
APTRS (Automated Penetration Testing Reporting System) is a Python and Django-based automated reporting tool designed for penetration testers and security organizations. In 1.0, there is a vulnerability in the web application's handling of user-supplied input that is incorporated into a Jinja2 template. Specifically, when user input is improperly sanitized or validated, an attacker can inject Jinja2 syntax into the template, causing the server to execute arbitrary code. For example, an attacker might be able to inject expressions like {{ config }}, {{ self.class.mro[1].subclasses() }}, or more dangerous payloads that trigger execution of arbitrary Python code. The vulnerability can be reproduced by submitting crafted input to all the template fields handled by ckeditor, that are passed directly to a Jinja2 template. If the input is rendered without sufficient sanitization, it results in the execution of malicious Jinja2 code on the server.
Published: 2024-12-23T17:23:57.120Z
Updated: 2024-12-24T01:32:59.318Z
Reference links
Imported from gcve-enriched-dumps CVE data

Contribute

You can submit an edit proposal for this CPE entry or suggest a related product/vendor addition using the action button above.