Approved changes feed: RSS · Atom

cpe:2.3:a:tablepress:tablepress:*:*:*:*:*:wordpress:*:*

part: a version: * update: *

VendorTablepress (7290ec2d-7ac7-5127-80dd-faa07cb78ce8)
ProductTablepress (be8da7ae-b15c-5588-927a-e74fe667ccbc)
Edition*
Language*
Software edition*
Target softwarewordpress
Target hardware*
Other*

Notes

Imported from purl2cpe mapping

PURL mappings

PURLSourceLast updated
pkg:github/tobiasbg/tablepress purl2cpe 2026-06-01 10:13:30.853406
pkg:github/wp-plugins/tablepress purl2cpe 2026-06-01 10:13:30.853408

Vulnerability references

IdentifiercpeApplicabilitySubmitteddb.gcve.eu detailsRationale
CVE:CVE-2025-5096 vulnerable 2026-06-08 07:35:24.151505 TablePress <= 3.1.2 - Authenticated (Contributor+) DOM-Based Stored Cross-Site Scripting via Multiple Parameters
MEDIUM (6.4)
The TablePress plugin for WordPress is vulnerable to DOM-Based Stored Cross-Site Scripting via the 'data-caption', 'data-s-content-padding', 'data-s-title', and 'data-footer' data-attributes in all versions up to, and including, 3.1.2 due to insufficient input sanitization and output escaping. This makes it possible for authenticated attackers, with Contributor-level access and above, to inject arbitrary web scripts in pages that will execute whenever a user accesses an injected page.
Published: 2025-05-23T08:23:39.711Z
Updated: 2026-04-08T17:24:00.375Z
Reference links
Imported from gcve-enriched-dumps CVE data
CVE:CVE-2025-2685 vulnerable 2026-06-08 07:16:58.064371 TablePress – Tables in WordPress made easy <= 3.0.4 - Authenticated (Author+) Stored Cross-Site Scripting
MEDIUM (6.4)
The TablePress – Tables in WordPress made easy plugin for WordPress is vulnerable to Stored Cross-Site Scripting via the ‘table-name’ parameter in all versions up to, and including, 3.0.4 due to insufficient input sanitization and output escaping. This makes it possible for authenticated attackers, with Author-level access and above, to inject arbitrary web scripts in pages that will execute whenever a user accesses an injected page.
Published: 2025-03-27T05:22:30.339Z
Updated: 2026-04-08T17:29:13.872Z
Reference links
Imported from gcve-enriched-dumps CVE data
CVE:CVE-2024-9595 vulnerable 2026-06-08 07:00:28.288691 TablePress <= 2.4.2 - Authenticated (Author+) Stored Cross-Site Scripting
MEDIUM (6.4)
The TablePress – Tables in WordPress made easy plugin for WordPress is vulnerable to Stored Cross-Site Scripting via the table cell content in all versions up to, and including, 2.4.2 due to insufficient input sanitization and output escaping. This makes it possible for authenticated attackers, with Author-level access and above, to inject arbitrary web scripts in pages that will execute whenever a user accesses an injected page.
Published: 2024-10-12T08:41:06.715Z
Updated: 2026-04-08T17:35:22.057Z
Reference links
Imported from gcve-enriched-dumps CVE data
CVE:CVE-2024-4354 vulnerable 2026-06-08 06:50:17.570393 TablePress – Tables in WordPress made easy <= 2.3 - Authenticated (Author+) Server-Side Request Forgery via DNS Rebind
MEDIUM (6.4)
The TablePress – Tables in WordPress made easy plugin for WordPress is vulnerable to Server-Side Request Forgery in all versions up to, and including, 2.3 via the get_files_to_import() function. This makes it possible for authenticated attackers, with author-level access and above, to make web requests to arbitrary locations originating from the web application and can be used to query and modify information from internal services. Due to the complex nature of protecting against DNS rebind attacks in WordPress software, we settled on the developer simply restricting the usage of the URL import functionality to just administrators. While this is not optimal, we feel this poses a minimal risk to most site owners and ideally WordPress core would correct this issue in wp_safe_remote_get() and other functions.
Published: 2024-06-07T05:33:45.967Z
Updated: 2026-04-08T17:05:08.917Z
Reference links
Imported from gcve-enriched-dumps CVE data
CVE:CVE-2024-23825 vulnerable 2026-06-08 06:29:40.668329 TablePress SSRF vulnerability due to insufficient filtering of cloud provider hosts
LOW (3)
TablePress is a table plugin for Wordpress. For importing tables, TablePress makes external HTTP requests based on a URL that is provided by the user. That user input is filtered insufficiently, which makes it is possible to send requests to unintended network locations and receive responses. On sites in a cloud environment like AWS, an attacker can potentially make GET requests to the instance's metadata REST API. If the instance's configuration is insecure, this can lead to the exposure of internal data, including credentials. This vulnerability is fixed in 2.2.5.
Published: 2024-01-30T16:22:04.876Z
Updated: 2025-05-29T15:04:54.089Z
Reference links
Imported from gcve-enriched-dumps CVE data
CVE:CVE-2019-20180 vulnerable 2026-06-08 05:13:30.559213 db.gcve.eu details were skipped to keep the page responsive. Imported from gcve-enriched-dumps CVE data
CVE:CVE-2017-10889 vulnerable 2026-06-08 05:08:36.485953 db.gcve.eu details were skipped to keep the page responsive. Imported from gcve-enriched-dumps CVE data

Contribute

You can submit an edit proposal for this CPE entry or suggest a related product/vendor addition using the action button above.

Inspect record JSON

Open JSON directly

Open this panel to browse, search, copy or download the JSON record.