Approved changes feed: RSS · Atom
cpe:2.3:a:nextchat:nextchat:*:*:*:*:*:*:*:*part: a version: * update: *
| Vendor | Nextchat (a917d991-1e18-5a84-b820-829c11cd2d41) |
|---|---|
| Product | Nextchat (7975ded5-046e-507e-98bd-5cd0eabba63c) |
| Edition | * |
| Language | * |
| Software edition | * |
| Target software | * |
| Target hardware | * |
| Other | * |
Notes
Imported from purl2cpe mapping
PURL mappings
| PURL | Source | Last updated |
|---|---|---|
pkg:github/chatgptnextweb/nextchat |
purl2cpe | 2026-06-01 10:13:32.450866 |
Vulnerability references
| Identifier | cpeApplicability | Submitted | db.gcve.eu details | Rationale |
|---|---|---|---|---|
CVE:CVE-2026-118132 |
vulnerable | 2026-11-03 10:17:04.382888 |
CVE-2026-118132
NextChat version 2.16.1 contains a client‑side cross‑site scripting (XSS) vulnerability in the Plugin Editor due to unsafe rendering of externally supplied OpenAPI plugin schema content. When a plugin schema is loaded from a remote URL, the returned content is stored in plugin.content and later rendered using React’s dangerouslySetInnerHTML without proper sanitization. An attacker can host a malicious OpenAPI schema containing HTML or JavaScript markup and trick a user into loading it through the Plugin Editor, resulting in arbitrary JavaScript execution in the NextChat origin. Successful exploitation allows access to JavaScript‑readable cookies and other client‑side data associated with the NextChat application.
Published: 2026-10-27T17:38:13.552Z
Updated: 2026-11-04T17:00:53.282Z Reference links |
Imported from gcve-enriched-dumps CVE data |
CVE:CVE-2025-50735 |
vulnerable | 2026-06-08 07:31:11.053370 |
Details available
Directory traversal vulnerability in NextChat thru 2.16.0 due to the WebDAV proxy failing to canonicalize or reject dot path segments in its catch-all route, allowing attackers to gain sensitive information via authenticated or anonymous WebDAV endpoints.
Published: 2025-11-03T00:00:00.000Z
Updated: 2025-11-03T20:11:16.719Z |
Imported from gcve-enriched-dumps CVE data |
CVE:CVE-2023-49785 |
vulnerable | 2026-06-08 06:16:10.458872 |
NextChat vulnerable to Server-Side Request Forgery and Cross-site Scripting
CRITICAL (9.1)
NextChat, also known as ChatGPT-Next-Web, is a cross-platform chat user interface for use with ChatGPT. Versions 2.11.2 and prior are vulnerable to server-side request forgery and cross-site scripting. This vulnerability enables read access to internal HTTP endpoints but also write access using HTTP POST, PUT, and other methods. Attackers can also use this vulnerability to mask their source IP by forwarding malicious traffic intended for other Internet targets through these open proxies. As of time of publication, no patch is available, but other mitigation strategies are available. Users may avoid exposing the application to the public internet or, if exposing the application to the internet, ensure it is an isolated network with no access to any other internal resources.
Published: 2024-03-11T23:26:10.773Z
Updated: 2024-08-19T07:48:00.560Z |
Imported from gcve-enriched-dumps CVE data |
Contribute
You can submit an edit proposal for this CPE entry or suggest a related product/vendor addition using the action button above.
Inspect record JSON
Open this panel to browse, search, copy or download the JSON record.