Approved changes feed: RSS · Atom
cpe:2.3:a:poppler:poppler:0.12.0:*:*:*:*:*:*:*part: a version: 0.12.0 update: *
| Vendor | Poppler (98aae7ff-3584-5962-ae0e-9e263082a752) |
|---|---|
| Product | Poppler (38483a4d-8b57-5752-9bd5-671c83322e0c) |
| Edition | * |
| Language | * |
| Software edition | * |
| Target software | * |
| Target hardware | * |
| Other | * |
Notes
Imported from purl2cpe mapping
PURL mappings
| PURL | Source | Last updated |
|---|---|---|
pkg:github/freedesktop/poppler |
purl2cpe | 2026-06-01 10:13:41.200122 |
pkg:rpm/fedora/poppler |
purl2cpe | 2026-06-01 10:13:41.200125 |
pkg:rpm/opensuse/poppler |
purl2cpe | 2026-06-01 10:13:41.200127 |
Vulnerability references
| Identifier | cpeApplicability | Submitted | db.gcve.eu details | Rationale |
|---|---|---|---|---|
CVE:CVE-2010-3704 |
vulnerable | 2026-06-08 04:55:16.477910 |
Details available
The FoFiType1::parse function in fofi/FoFiType1.cc in the PDF parser in xpdf before 3.02pl5, poppler 0.8.7 and possibly other versions up to 0.15.1, kdegraphics, and possibly other products allows context-dependent attackers to cause a denial of service (crash) and possibly execute arbitrary code via a PDF file with a crafted PostScript Type1 font that contains a negative array index, which bypasses input validation and triggers memory corruption.
Published: 2010-11-05T17:00:00.000Z
Updated: 2024-08-07T03:18:53.042Z Reference links
|
Imported from gcve-enriched-dumps CVE data |
CVE:CVE-2010-3703 |
vulnerable | 2026-06-08 04:55:16.460688 |
Details available
The PostScriptFunction::PostScriptFunction function in poppler/Function.cc in the PDF parser in poppler 0.8.7 and possibly other versions up to 0.15.1, and possibly other products, allows context-dependent attackers to cause a denial of service (crash) via a PDF file that triggers an uninitialized pointer dereference.
Published: 2010-11-05T17:00:00.000Z
Updated: 2024-08-07T03:18:52.924Z |
Imported from gcve-enriched-dumps CVE data |
CVE:CVE-2009-3938 |
vulnerable | 2026-06-08 04:51:45.398189 |
Details available
Buffer overflow in the ABWOutputDev::endWord function in poppler/ABWOutputDev.cc in Poppler (aka libpoppler) 0.10.6, 0.12.0, and possibly other versions, as used by the Abiword pdftoabw utility, allows user-assisted remote attackers to cause a denial of service and possibly execute arbitrary code via a crafted PDF file.
Published: 2009-11-13T16:00:00.000Z
Updated: 2024-08-07T06:45:50.643Z |
Imported from gcve-enriched-dumps CVE data |
CVE:CVE-2009-3607 |
vulnerable | 2026-06-08 04:51:42.887568 |
Details available
Integer overflow in the create_surface_from_thumbnail_data function in glib/poppler-page.cc in Poppler 0.x allows remote attackers to cause a denial of service (memory corruption) or possibly execute arbitrary code via a crafted PDF document that triggers a heap-based buffer overflow. NOTE: some of these details are obtained from third party information.
Published: 2009-10-21T17:00:00.000Z
Updated: 2024-08-07T06:31:10.561Z |
Imported from gcve-enriched-dumps CVE data |
CVE:CVE-2009-3606 |
vulnerable | 2026-06-08 04:51:42.885857 |
Details available
Integer overflow in the PSOutputDev::doImageL1Sep function in Xpdf before 3.02pl4, and Poppler 0.x, as used in kdegraphics KPDF, might allow remote attackers to execute arbitrary code via a crafted PDF document that triggers a heap-based buffer overflow.
Published: 2009-10-21T17:00:00.000Z
Updated: 2024-08-07T06:31:11.027Z |
Imported from gcve-enriched-dumps CVE data |
CVE:CVE-2009-3604 |
vulnerable | 2026-06-08 04:51:42.882273 | db.gcve.eu details were skipped to keep the page responsive. | Imported from gcve-enriched-dumps CVE data |
Contribute
You can submit an edit proposal for this CPE entry or suggest a related product/vendor addition using the action button above.
Inspect record JSON
Open this panel to browse, search, copy or download the JSON record.