Approved changes feed: RSS · Atom
cpe:2.3:a:plug_project:plug:*:*:*:*:*:*:*:*part: a version: * update: *
| Vendor | Plug Project (e04f7a9c-6c17-577b-bc01-4eb654d958bb) |
|---|---|
| Product | Plug (6ea2c0d0-7e4d-5f3a-adbf-d01500b11016) |
| Edition | * |
| Language | * |
| Software edition | * |
| Target software | * |
| Target hardware | * |
| Other | * |
Notes
Imported from purl2cpe mapping
PURL mappings
| PURL | Source | Last updated |
|---|---|---|
pkg:github/elixir-plug/plug |
purl2cpe | 2026-06-01 10:13:48.134355 |
Vulnerability references
| Identifier | cpeApplicability | Submitted | db.gcve.eu details | Rationale |
|---|---|---|---|---|
CVE:CVE-2026-8468 |
vulnerable | 2026-06-08 08:08:58.383577 |
Unbounded buffer accumulation in multipart header parsing causes denial of service in plug
Allocation of Resources Without Limits or Throttling vulnerability in plug_project plug allows denial of service via unbounded buffer accumulation in multipart header parsing.
'Elixir.Plug.Conn':read_part_headers/2 in lib/plug/conn.ex does not obey its :length parameter. There is no upper bound on the size of the accumulated buffer. By contrast, the sibling function read_part_body has an explicit byte_size(acc) > length guard that stops accumulation once a limit is reached. No such guard exists in read_part_headers. An unauthenticated remote attacker can exhaust server memory by sending a crafted multipart/form-data request, causing a denial of service.
This issue affects plug from 1.4.0 before 1.15.4, 1.16.3, 1.17.1, 1.18.2, and 1.19.2.
Published: 2026-05-14T10:29:51.062Z
Updated: 2026-05-27T15:41:29.241Z Reference links |
Imported from gcve-enriched-dumps CVE data |
CVE:CVE-2018-1000883 |
vulnerable | 2026-06-08 05:10:26.183460 |
Details available
Elixir Plug Plug version All contains a Header Injection vulnerability in Connection that can result in Given a cookie value, Headers can be added. This attack appear to be exploitable via Crafting a value to be sent as a cookie. This vulnerability appears to have been fixed in >= 1.3.5 or ~> 1.2.5 or ~> 1.1.9 or ~> 1.0.6.
Published: 2018-12-20T20:00:00.000Z
Updated: 2024-09-17T00:40:42.841Z |
Imported from gcve-enriched-dumps CVE data |
CVE:CVE-2017-1000053 |
vulnerable | 2026-06-08 05:08:33.680832 |
Details available
Elixir Plug before v1.0.4, v1.1.7, v1.2.3 and v1.3.2 is vulnerable to arbitrary code execution in the deserialization functions of Plug.Session.
Published: 2017-07-13T20:00:00.000Z
Updated: 2024-08-05T21:53:06.256Z Reference links |
Imported from gcve-enriched-dumps CVE data |
CVE:CVE-2017-1000052 |
vulnerable | 2026-06-08 05:08:33.680423 |
Details available
Elixir Plug before v1.0.4, v1.1.7, v1.2.3 and v1.3.2 is vulnerable to null byte injection in the Plug.Static component, which may allow users to bypass filetype restrictions.
Published: 2017-07-13T20:00:00.000Z
Updated: 2024-08-05T21:53:06.279Z Reference links |
Imported from gcve-enriched-dumps CVE data |
Contribute
You can submit an edit proposal for this CPE entry or suggest a related product/vendor addition using the action button above.
Inspect record JSON
Open this panel to browse, search, copy or download the JSON record.