Approved changes feed: RSS · Atom
cpe:2.3:a:qbnz:geshi:*:*:*:*:*:*:*:*part: a version: * update: *
| Vendor | Qbnz (19e21e7b-4abb-521c-b9e1-b6c99d3dfa2c) |
|---|---|
| Product | Geshi (9df7b167-7ea3-5a91-9f16-33d797fbc545) |
| Edition | * |
| Language | * |
| Software edition | * |
| Target software | * |
| Target hardware | * |
| Other | * |
Notes
Imported from purl2cpe mapping
PURL mappings
| PURL | Source | Last updated |
|---|---|---|
pkg:deb/debian/php-geshi |
purl2cpe | 2026-06-01 10:14:06.900206 |
pkg:deb/ubuntu/php-geshi |
purl2cpe | 2026-06-01 10:14:06.900209 |
pkg:github/geshi/geshi-1.0 |
purl2cpe | 2026-06-01 10:14:06.900212 |
pkg:rpm/fedora/php-geshi |
purl2cpe | 2026-06-01 10:14:06.900214 |
pkg:rpm/opensuse/php-geshi |
purl2cpe | 2026-06-01 10:14:06.900217 |
pkg:sourceforge/geshi |
purl2cpe | 2026-06-01 10:14:06.900220 |
Vulnerability references
| Identifier | cpeApplicability | Submitted | db.gcve.eu details | Rationale |
|---|---|---|---|---|
CVE:CVE-2025-2123 |
vulnerable | 2026-06-08 07:14:58.053836 |
GeSHi CSS cssgen.php get_var cross site scripting
LOW (3.5)
A vulnerability, which was classified as problematic, has been found in GeSHi up to 1.0.9.1. Affected by this issue is the function get_var of the file /contrib/cssgen.php of the component CSS Handler. The manipulation of the argument default-styles/keywords-1/keywords-2/keywords-3/keywords-4/comments leads to cross site scripting. The attack may be launched remotely. The exploit has been disclosed to the public and may be used.
Published: 2025-03-09T15:00:12.269Z
Updated: 2025-03-10T15:35:51.889Z |
Imported from gcve-enriched-dumps CVE data |
CVE:CVE-2012-3522 |
vulnerable | 2026-06-08 05:02:10.477934 |
Details available
Cross-site scripting (XSS) vulnerability in contrib/langwiz.php in GeSHi before 1.0.8.11 allows remote attackers to inject arbitrary web script or HTML via unspecified vectors.
Published: 2014-06-13T14:00:00.000Z
Updated: 2024-08-06T20:05:12.752Z Reference links
|
Imported from gcve-enriched-dumps CVE data |
CVE:CVE-2012-3521 |
vulnerable | 2026-06-08 05:02:10.474139 |
Details available
Multiple directory traversal vulnerabilities in the cssgen contrib module in GeSHi before 1.0.8.11 allow remote attackers to read arbitrary files via a .. (dot dot) in the (1) geshi-path or (2) geshi-lang-path parameter.
Published: 2014-06-13T14:00:00.000Z
Updated: 2024-08-06T20:05:12.782Z Reference links
|
Imported from gcve-enriched-dumps CVE data |
Contribute
You can submit an edit proposal for this CPE entry or suggest a related product/vendor addition using the action button above.
Inspect record JSON
Open this panel to browse, search, copy or download the JSON record.