Authenticator
Approved changes feed: RSS · Atom
cpe:2.3:a:authenticator:authenticator:*:*:*:*:*:*:*:*
part: a version: * update: *
| Vendor | Authenticator (4b1b9927-9b7e-5474-af43-f42b719a5d2b) |
|---|---|
| Product | Authenticator (de411cc3-28ec-5b9f-a6ed-435ed7db3fab) |
| Edition | * |
| Language | * |
| Software edition | * |
| Target software | * |
| Target hardware | * |
| Other | * |
| Notes | Imported from purl2cpe mapping |
PURL mappings
| PURL | Source | Last updated |
|---|---|---|
pkg:github/authenticator-extension/authenticator |
purl2cpe | 2026-06-01 10:14:35.802674 |
Vulnerability references
| Identifier | cpeApplicability | Submitted | db.gcve.eu details | Rationale |
|---|---|---|---|---|
CVE:CVE-2024-45394 |
vulnerable | 2026-06-08 06:48:06.050356 |
Secret encryption vulnerable to brute-force attacks
HIGH (8.8)
Authenticator is a browser extension that generates two-step verification codes. In versions 7.0.0 and below, encryption keys for user data were stored encrypted at-rest using only AES-256 and the EVP_BytesToKey KDF. Therefore, attackers with a copy of a user's data are able to brute-force the user's encryption key. Users on version 8.0.0 and above are automatically migrated away from the weak encoding on first login. Users should destroy encrypted backups made with versions prior to 8.0.0.
Published: 2024-09-03T20:15:42.769Z
Updated: 2024-10-09T14:27:06.537Z |
Imported from gcve-enriched-dumps CVE data |
Contribute
You can submit an edit proposal for this CPE entry or suggest a related product/vendor addition using the action button above.