Approved changes feed: RSS · Atom

cpe:2.3:a:westes:flex:*:*:*:*:*:*:*:*

part: a version: * update: *

VendorWestes (5c2498a7-cbbc-52cf-a0f1-03b8289fa7aa)
ProductFlex (b69aeba9-fd34-5835-a12d-2aef085a8cb9)
Edition*
Language*
Software edition*
Target software*
Target hardware*
Other*

Notes

Imported from purl2cpe mapping

PURL mappings

PURLSourceLast updated
pkg:deb/debian/flex purl2cpe 2026-06-01 10:14:41.435512
pkg:deb/ubuntu/flex purl2cpe 2026-06-01 10:14:41.435516
pkg:github/westes/flex purl2cpe 2026-06-01 10:14:41.435518
pkg:rpm/fedora/flex purl2cpe 2026-06-01 10:14:41.435521
pkg:rpm/opensuse/flex purl2cpe 2026-06-01 10:14:41.435524
pkg:sourceforge/flex purl2cpe 2026-06-01 10:14:41.435527

Vulnerability references

IdentifiercpeApplicabilitySubmitteddb.gcve.eu detailsRationale
CVE:CVE-2016-6354 vulnerable 2026-06-08 05:07:59.669120 Details available
Heap-based buffer overflow in the yy_get_next_buffer function in Flex before 2.6.1 might allow context-dependent attackers to cause a denial of service or possibly execute arbitrary code via vectors involving num_to_read.
Published: 2016-09-21T14:00:00.000Z
Updated: 2024-08-06T01:29:19.088Z
Reference links
Imported from gcve-enriched-dumps CVE data
CVE:CVE-2006-0459 vulnerable 2026-06-08 04:48:54.004884 Details available
flex.skl in Will Estes and John Millaway Fast Lexical Analyzer Generator (flex) before 2.5.33 does not allocate enough memory for grammars containing (1) REJECT statements or (2) trailing context rules, which causes flex to generate code that contains a buffer overflow that might allow context-dependent attackers to execute arbitrary code.
Published: 2006-03-29T23:00:00.000Z
Updated: 2024-08-07T16:34:14.696Z
Reference links
Imported from gcve-enriched-dumps CVE data

Contribute

You can submit an edit proposal for this CPE entry or suggest a related product/vendor addition using the action button above.

Inspect record JSON

Open JSON directly

Open this panel to browse, search, copy or download the JSON record.