Approved changes feed: RSS · Atom

cpe:2.3:a:tukaani:xz:*:*:*:*:*:*:*:*

part: a version: * update: *

VendorTukaani (0aaa3f63-17f8-533c-b9ee-c2ee201d660e)
ProductXz (d0ebc392-5951-5489-942e-c7b7d0dc4ac7)
Edition*
Language*
Software edition*
Target software*
Target hardware*
Other*

Notes

Imported from purl2cpe mapping

PURL mappings

PURLSourceLast updated
pkg:github/bminor/xz purl2cpe 2026-06-01 10:14:44.420269
pkg:github/smart-make/xz purl2cpe 2026-06-01 10:14:44.420273
pkg:gitlab/redhat/xz purl2cpe 2026-06-01 10:14:44.420277
pkg:rpm/centos/xz purl2cpe 2026-06-01 10:14:44.420281
pkg:rpm/fedora/xz purl2cpe 2026-06-01 10:14:44.420284
pkg:rpm/opensuse/xz purl2cpe 2026-06-01 10:14:44.420288

Vulnerability references

IdentifiercpeApplicabilitySubmitteddb.gcve.eu detailsRationale
CVE:CVE-2026-34743 vulnerable 2026-06-08 07:59:13.060933 XZ Utils: Buffer overflow in lzma_index_append()
XZ Utils provide a general-purpose data-compression library plus command-line tools. Prior to version 5.8.3, if lzma_index_decoder() was used to decode an Index that contained no Records, the resulting lzma_index was left in a state where where a subsequent lzma_index_append() would allocate too little memory, and a buffer overflow would occur. This issue has been patched in version 5.8.3.
Published: 2026-04-02T18:36:37.450Z
Updated: 2026-07-21T22:19:21.175Z
Reference links
Imported from gcve-enriched-dumps CVE data
CVE:CVE-2024-47611 vulnerable 2026-06-08 06:48:12.936407 XZ Utils on Microsoft Windows platform are vulnerable to argument injection
XZ Utils provide a general-purpose data-compression library plus command-line tools. When built for native Windows (MinGW-w64 or MSVC), the command line tools from XZ Utils 5.6.2 and older have a command line argument injection vulnerability. If a command line contains Unicode characters (for example, filenames) that don't exist in the current legacy code page, the characters are converted to similar-looking characters with best-fit mapping. Some best-fit mappings result in ASCII characters that change the meaning of the command line, which can be exploited with malicious filenames to do argument injection or directory traversal attacks. This vulnerability is fixed in 5.6.3. Command line tools built for Cygwin or MSYS2 are unaffected. liblzma is unaffected.
Published: 2024-10-02T14:16:07.318Z
Updated: 2024-11-21T16:55:27.310Z
Reference links
Imported from gcve-enriched-dumps CVE data
CVE:CVE-2022-1271 vulnerable 2026-06-08 05:39:12.592066 Details available
An arbitrary file write vulnerability was found in GNU gzip's zgrep utility. When zgrep is applied on the attacker's chosen file name (for example, a crafted file name), this can overwrite an attacker's content to an arbitrary attacker-selected file. This flaw occurs due to insufficient validation when processing filenames with two or more newlines where selected content and the target file names are embedded in crafted multi-line file names. This flaw allows a remote, low privileged attacker to force zgrep to write arbitrary files on the system.
Published: 2022-08-31T15:33:00.000Z
Updated: 2026-10-14T12:25:51.618Z
Reference links
Imported from gcve-enriched-dumps CVE data

Contribute

You can submit an edit proposal for this CPE entry or suggest a related product/vendor addition using the action button above.

Inspect record JSON

Open JSON directly

Open this panel to browse, search, copy or download the JSON record.