Approved changes feed: RSS · Atom

cpe:2.3:a:xwp:stream:*:*:*:*:*:*:*:*

part: a version: * update: *

VendorXwp (04b62bbe-68d9-5dfd-9f8b-88a19e411b32)
ProductStream (39b9a5d5-25db-5174-bb81-5c275d5b6dfe)
Edition*
Language*
Software edition*
Target software*
Target hardware*
Other*

Notes

Imported from purl2cpe mapping

PURL mappings

PURLSourceLast updated
pkg:github/xwp/stream purl2cpe 2026-06-01 10:14:44.719285

Vulnerability references

IdentifiercpeApplicabilitySubmitteddb.gcve.eu detailsRationale
CVE:CVE-2024-7423 vulnerable 2026-06-08 06:58:22.152596 Stream <= 4.0.1 - Cross-Site Request Forgery to Arbitrary Options Update
HIGH (8.8)
The Stream plugin for WordPress is vulnerable to Cross-Site Request Forgery in all versions up to, and including, 4.0.1. This is due to missing or incorrect nonce validation on the network_options_action() function. This makes it possible for unauthenticated attackers to update arbitrary options that can lead to DoS or privilege escalation via a forged request granted they can trick a site administrator into performing an action such as clicking on a link.
Published: 2024-09-13T15:10:40.919Z
Updated: 2026-04-08T17:11:32.200Z
Reference links
Imported from gcve-enriched-dumps CVE data
CVE:CVE-2024-13879 vulnerable 2026-06-08 06:25:38.684716 Stream <= 4.0.2 - Authenticated (Admin+) Server-Side Request Forgery
MEDIUM (5.5)
The Stream plugin for WordPress is vulnerable to Server-Side Request Forgery in all versions up to, and including, 4.0.2 due to insufficient validation on the webhook feature. This makes it possible for authenticated attackers, with administrator-level access and above, to make web requests to arbitrary locations originating from the web application which can be used to query and modify information from internal services.
Published: 2025-02-17T15:21:19.607Z
Updated: 2026-04-08T17:04:49.373Z
Reference links
Imported from gcve-enriched-dumps CVE data
CVE:CVE-2022-43490 vulnerable 2026-06-08 05:49:32.138294 WordPress Stream Plugin <= 3.9.2 is vulnerable to Cross Site Request Forgery (CSRF)
MEDIUM (5.4)
Cross-Site Request Forgery (CSRF) vulnerability in XWP Stream plugin <= 3.9.2 versions.
Published: 2023-05-25T10:17:18.016Z
Updated: 2026-04-28T16:07:50.819Z
Reference links
Imported from gcve-enriched-dumps CVE data
CVE:CVE-2022-43450 vulnerable 2026-06-08 05:49:31.984780 WordPress Stream Plugin <= 3.9.2 is vulnerable to Insecure Direct Object References (IDOR)
MEDIUM (4.3)
Authorization Bypass Through User-Controlled Key vulnerability in XWP Stream.This issue affects Stream: from n/a through 3.9.2.
Published: 2023-12-19T21:24:05.517Z
Updated: 2026-04-28T16:07:50.669Z
Reference links
Imported from gcve-enriched-dumps CVE data

Contribute

You can submit an edit proposal for this CPE entry or suggest a related product/vendor addition using the action button above.

Inspect record JSON

Open JSON directly

Open this panel to browse, search, copy or download the JSON record.