Approved changes feed: RSS · Atom
cpe:2.3:a:polkit_project:polkit:*:*:*:*:*:*:*:*part: a version: * update: *
| Vendor | Polkit Project (e45019f9-c80c-5681-a97a-d7cb562bccad) |
|---|---|
| Product | Polkit (39dd2df1-231f-5214-ae36-87331f28f3c6) |
| Edition | * |
| Language | * |
| Software edition | * |
| Target software | * |
| Target hardware | * |
| Other | * |
Notes
Imported from purl2cpe mapping
PURL mappings
| PURL | Source | Last updated |
|---|---|---|
pkg:github/policykit/policykit |
purl2cpe | 2026-06-01 10:14:48.299495 |
pkg:gitlab/redhat/polkit |
purl2cpe | 2026-06-01 10:14:48.299497 |
pkg:rpm/fedora/polkit |
purl2cpe | 2026-06-01 10:14:48.299498 |
pkg:rpm/opensuse/policykit |
purl2cpe | 2026-06-01 10:14:48.299500 |
Vulnerability references
| Identifier | cpeApplicability | Submitted | db.gcve.eu details | Rationale |
|---|---|---|---|---|
CVE:CVE-2021-4034 |
vulnerable | 2026-06-08 05:38:08.125746 |
Details available
A local privilege escalation vulnerability was found on polkit's pkexec utility. The pkexec application is a setuid tool designed to allow unprivileged users to run commands as privileged users according predefined policies. The current version of pkexec doesn't handle the calling parameters count correctly and ends trying to execute environment variables as commands. An attacker can leverage this by crafting environment variables in such a way it'll induce pkexec to execute arbitrary code. When successfully executed the attack can cause a local privilege escalation given unprivileged users administrative rights on the target machine.
Published: 2022-01-28T00:00:00.000Z
Updated: 2026-08-15T03:55:29.140Z Reference links
|
Imported from gcve-enriched-dumps CVE data |
CVE:CVE-2021-3560 |
vulnerable | 2026-06-08 05:33:52.789988 |
Details available
It was found that polkit could be tricked into bypassing the credential checks for D-Bus requests, elevating the privileges of the requestor to the root user. This flaw could be used by an unprivileged local attacker to, for example, create a new local administrator. The highest threat from this vulnerability is to data confidentiality and integrity as well as system availability.
Published: 2022-02-16T00:00:00.000Z
Updated: 2025-10-21T23:15:46.259Z Reference links |
Imported from gcve-enriched-dumps CVE data |
CVE:CVE-2018-1116 |
vulnerable | 2026-06-08 05:11:16.952079 |
Details available
MEDIUM (4.7)
A flaw was found in polkit before version 0.116. The implementation of the polkit_backend_interactive_authority_check_authorization function in polkitd allows to test for authentication and trigger authentication of unrelated processes owned by other users. This may result in a local DoS and information disclosure.
Published: 2018-07-10T19:00:00.000Z
Updated: 2024-08-05T03:51:48.873Z |
Imported from gcve-enriched-dumps CVE data |
CVE:CVE-2015-4625 |
vulnerable | 2026-06-08 05:06:40.325512 |
Details available
Integer overflow in the authentication_agent_new_cookie function in PolicyKit (aka polkit) before 0.113 allows local users to gain privileges by creating a large number of connections, which triggers the issuance of a duplicate cookie value.
Published: 2015-10-26T19:00:00.000Z
Updated: 2024-08-06T06:18:12.015Z Reference links
|
Imported from gcve-enriched-dumps CVE data |
CVE:CVE-2015-3256 |
vulnerable | 2026-06-08 05:06:37.823793 |
Details available
PolicyKit (aka polkit) before 0.113 allows local users to cause a denial of service (memory corruption and polkitd daemon crash) and possibly gain privileges via unspecified vectors, related to "javascript rule evaluation."
Published: 2015-10-26T19:00:00.000Z
Updated: 2024-08-06T05:39:32.094Z Reference links |
Imported from gcve-enriched-dumps CVE data |
CVE:CVE-2015-3255 |
vulnerable | 2026-06-08 05:06:37.823429 | db.gcve.eu details were skipped to keep the page responsive. | Imported from gcve-enriched-dumps CVE data |
CVE:CVE-2015-3218 |
vulnerable | 2026-06-08 05:06:37.614969 | db.gcve.eu details were skipped to keep the page responsive. | Imported from gcve-enriched-dumps CVE data |
CVE:CVE-2013-4288 |
vulnerable | 2026-06-08 05:04:35.267434 | db.gcve.eu details were skipped to keep the page responsive. | Imported from gcve-enriched-dumps CVE data |
Contribute
You can submit an edit proposal for this CPE entry or suggest a related product/vendor addition using the action button above.
Inspect record JSON
Open this panel to browse, search, copy or download the JSON record.