Approved changes feed: RSS · Atom

cpe:2.3:a:simplefilelist:simple-file-list:*:*:*:*:*:wordpress:*:*

part: a version: * update: *

VendorSimplefilelist (eab7a3eb-72ea-5ccb-a35c-71d74118eeb4)
ProductSimple File List (bcc4d568-0c5f-595d-896e-59081cb29111)
Edition*
Language*
Software edition*
Target softwarewordpress
Target hardware*
Other*
NotesImported from purl2cpe mapping

PURL mappings

PURLSourceLast updated
pkg:github/wpplugins/simple-file-list purl2cpe 2026-06-01 10:14:56.579974

Vulnerability references

IdentifiercpeApplicabilitySubmitteddb.gcve.eu detailsRationale
CVE:CVE-2022-3208 vulnerable 2026-06-08 05:47:19.720091 Simple File List < 4.4.13 - Page Creation via CSRF
The Simple File List WordPress plugin before 4.4.12 does not implement nonce checks, which could allow attackers to make a logged in admin create new page and change it's content via a CSRF attack.
Published: 2022-10-10T00:00:00.000Z
Updated: 2024-08-03T01:00:10.619Z
Reference links
Imported from gcve-enriched-dumps CVE data
CVE:CVE-2022-3207 vulnerable 2026-06-08 05:47:19.719786 Simple File List < 4.4.12 - Admin+ Stored Cross-Site Scripting
The Simple File List WordPress plugin before 4.4.12 does not sanitise and escape some of its settings, which could allow high privilege users such as admin to perform Stored Cross-Site Scripting attacks even when the unfiltered_html capability is disallowed (for example in multisite setup)
Published: 2022-10-10T00:00:00.000Z
Updated: 2024-08-03T01:00:10.617Z
Reference links
Imported from gcve-enriched-dumps CVE data
CVE:CVE-2022-3062 vulnerable 2026-06-08 05:47:19.115409 Simple File List < 4.4.12 - Reflected Cross-Site Scripting
The Simple File List WordPress plugin before 4.4.12 does not escape parameters before outputting them back in attributes, leading to Reflected Cross-Site Scripting
Published: 2022-09-26T12:35:39.000Z
Updated: 2025-05-22T14:13:49.522Z
Reference links
Imported from gcve-enriched-dumps CVE data
CVE:CVE-2022-1119 vulnerable 2026-06-08 05:39:12.248941 Simple File List <= 3.2.7 - Arbitrary File Download
HIGH (7.5)
The Simple File List WordPress plugin is vulnerable to Arbitrary File Download via the eeFile parameter found in the ~/includes/ee-downloader.php file due to missing controls which makes it possible unauthenticated attackers to supply a path to a file that will subsequently be downloaded, in versions up to and including 3.2.7.
Published: 2022-04-19T20:26:35.000Z
Updated: 2026-04-08T17:35:16.664Z
Reference links
Imported from gcve-enriched-dumps CVE data
CVE:CVE-2020-12832 vulnerable 2026-06-08 05:17:59.430209 Details available
WordPress Plugin Simple File List before 4.2.8 is prone to a vulnerability that lets attackers delete arbitrary files because the application fails to properly verify user-supplied input.
Published: 2020-05-13T17:52:37.000Z
Updated: 2024-08-04T12:04:22.887Z
Reference links
Imported from gcve-enriched-dumps CVE data

Contribute

You can submit an edit proposal for this CPE entry or suggest a related product/vendor addition using the action button above.