Approved changes feed: RSS · Atom
cpe:2.3:a:pseitz:lz4_flex:*:*:*:*:*:rust:*:*part: a version: * update: *
| Vendor | Pseitz (95a9be3e-3e70-56e9-b999-1e3b7f5f3da5) |
|---|---|
| Product | Lz4 Flex (34afb981-db1d-58d5-8e1c-434dbd93ebdc) |
| Edition | * |
| Language | * |
| Software edition | * |
| Target software | rust |
| Target hardware | * |
| Other | * |
Notes
Imported from purl2cpe mapping
PURL mappings
| PURL | Source | Last updated |
|---|---|---|
pkg:github/pseitz/lz4_flex |
purl2cpe | 2026-06-01 10:15:01.953785 |
Vulnerability references
| Identifier | cpeApplicability | Submitted | db.gcve.eu details | Rationale |
|---|---|---|---|---|
CVE:CVE-2026-32829 |
vulnerable | 2026-06-08 07:57:18.176641 |
lz4_flex: Decompression can leak information from uninitialized memory or reused output buffer
lz4_flex is a pure Rust implementation of LZ4 compression/decompression. In versions 0.11.5 and below, and 0.12.0, decompressing invalid LZ4 data can leak sensitive information from uninitialized memory or from previous decompression operations. The library fails to properly validate offset values during LZ4 "match copy operations," allowing out-of-bounds reads from the output buffer. The block-based API functions (`decompress_into`, `decompress_into_with_dict`, and others when `safe-decode` is disabled) are affected, while all frame APIs are unaffected. The impact is potential exposure of sensitive data and secrets through crafted or malformed LZ4 input. This issue has been fixed in versions 0.11.6 and 0.12.1.
Published: 2026-03-20T00:49:12.893Z
Updated: 2026-09-17T12:04:33.082Z |
Imported from gcve-enriched-dumps CVE data |
Contribute
You can submit an edit proposal for this CPE entry or suggest a related product/vendor addition using the action button above.
Inspect record JSON
Open this panel to browse, search, copy or download the JSON record.