Approved changes feed: RSS · Atom
cpe:2.3:a:wp-ban_project:wp-ban:*:*:*:*:*:wordpress:*:*part: a version: * update: *
| Vendor | Wp Ban Project (7aa91765-c1ba-5d83-86e9-a8b8f3a342fa) |
|---|---|
| Product | Wp Ban (c7ee0143-a3d1-567b-8b6d-b8e23c5aa0bb) |
| Edition | * |
| Language | * |
| Software edition | * |
| Target software | wordpress |
| Target hardware | * |
| Other | * |
Notes
Imported from purl2cpe mapping
PURL mappings
| PURL | Source | Last updated |
|---|---|---|
pkg:github/lesterchan/wp-ban |
purl2cpe | 2026-06-01 10:15:13.935510 |
pkg:github/wp-plugins/wp-ban |
purl2cpe | 2026-06-01 10:15:13.935512 |
pkg:github/wpplugins/wp-ban |
purl2cpe | 2026-06-01 10:15:13.935513 |
Vulnerability references
| Identifier | cpeApplicability | Submitted | db.gcve.eu details | Rationale |
|---|---|---|---|---|
CVE:CVE-2022-4260 |
vulnerable | 2026-06-08 05:51:37.078566 |
WP-Ban < 1.69.1 - Admin+ Stored XSS
The WP-Ban WordPress plugin before 1.69.1 does not sanitise and escape some of its settings, which could allow high privilege users such as admin to perform Stored Cross-Site Scripting attacks even when the unfiltered_html capability is disallowed (for example in multisite setup).
Published: 2023-01-02T21:49:42.572Z
Updated: 2025-04-10T18:33:18.971Z |
Imported from gcve-enriched-dumps CVE data |
CVE:CVE-2021-4252 |
vulnerable | 2026-06-08 05:38:09.039314 |
WP-Ban ban-options.php toggle_checkbox cross site scripting
LOW (3.5)
A vulnerability, which was classified as problematic, has been found in WP-Ban. This issue affects the function toggle_checkbox of the file ban-options.php. The manipulation of the argument $_SERVER["HTTP_USER_AGENT"] leads to cross site scripting. The attack may be initiated remotely. The name of the patch is 13e0b1e922f3aaa3f8fcb1dd6d50200dd693fd76. It is recommended to apply a patch to fix this issue. The identifier VDB-216209 was assigned to this vulnerability.
Published: 2022-12-18T00:00:00.000Z
Updated: 2025-04-15T12:59:51.281Z |
Imported from gcve-enriched-dumps CVE data |
CVE:CVE-2014-6230 |
vulnerable | 2026-06-08 05:05:56.876972 |
Details available
WP-Ban plugin before 1.6.4 for WordPress, when running in certain configurations, allows remote attackers to bypass the IP blacklist via a crafted X-Forwarded-For header.
Published: 2014-10-25T00:00:00.000Z
Updated: 2024-08-06T12:10:13.300Z |
Imported from gcve-enriched-dumps CVE data |
Contribute
You can submit an edit proposal for this CPE entry or suggest a related product/vendor addition using the action button above.
Inspect record JSON
Open this panel to browse, search, copy or download the JSON record.