Approved changes feed: RSS · Atom

cpe:2.3:a:mpl-publisher:mpl-publisher:*:*:*:*:*:*:*:*

part: a version: * update: *

VendorMpl Publisher (4bb9e5c5-c744-575a-9002-93aa4dfc12f6)
ProductMpl Publisher (888b459f-c0de-5638-9e83-1feb7fa77bdc)
Edition*
Language*
Software edition*
Target software*
Target hardware*
Other*

Notes

Imported from purl2cpe mapping

PURL mappings

PURLSourceLast updated
pkg:github/common-repository/mpl-publisher purl2cpe 2026-07-28 16:41:06.919365
pkg:github/ferranfg/mpl-publisher purl2cpe 2026-06-01 10:15:30.348415
pkg:github/wp-plugins/mpl-publisher purl2cpe 2026-06-01 10:15:30.348418

Vulnerability references

IdentifiercpeApplicabilitySubmitteddb.gcve.eu detailsRationale
CVE:CVE-2021-39343 vulnerable 2026-06-08 05:33:50.103378 MPL-Publisher – Self-publish your book & ebook <= 1.30.2 Authenticated Stored Cross-Site Scripting
MEDIUM (5.5)
The MPL-Publisher WordPress plugin is vulnerable to Stored Cross-Site Scripting due to insufficient input validation and sanitization via several parameters found in the ~/libs/PublisherController.php file which allowed attackers with administrative user access to inject arbitrary web scripts, in versions up to and including 1.30.2. This affects multi-site installations where unfiltered_html is disabled for administrators, and sites where unfiltered_html is disabled.
Published: 2021-10-19T14:14:56.445Z
Updated: 2025-02-14T17:53:05.336Z
Reference links
Imported from gcve-enriched-dumps CVE data

Contribute

You can submit an edit proposal for this CPE entry or suggest a related product/vendor addition using the action button above.

Inspect record JSON

Open JSON directly

Open this panel to browse, search, copy or download the JSON record.