Approved changes feed: RSS · Atom

cpe:2.3:a:dalli_project:dalli:*:*:*:*:*:ruby:*:*

part: a version: * update: *

VendorDalli Project (86b35097-8c3f-51da-b8ab-b834e7915778)
ProductDalli (bcd650e0-7b86-5166-8cd3-9d36b12224e4)
Edition*
Language*
Software edition*
Target softwareruby
Target hardware*
Other*

Notes

Imported from purl2cpe mapping

PURL mappings

PURLSourceLast updated
pkg:deb/debian/ruby-dalli purl2cpe 2026-06-01 10:15:49.990652
pkg:deb/ubuntu/ruby-dalli purl2cpe 2026-06-01 10:15:49.990654
pkg:gem/dalli purl2cpe 2026-06-01 10:15:49.990656
pkg:github/petergoldstein/dalli purl2cpe 2026-06-01 10:15:49.990658
pkg:rpm/fedora/rubygem-dalli purl2cpe 2026-06-01 10:15:49.990660
pkg:rpm/opensuse/rubygem-dalli purl2cpe 2026-06-01 10:15:49.990661

Vulnerability references

IdentifiercpeApplicabilitySubmitteddb.gcve.eu detailsRationale
CVE:CVE-2022-4064 vulnerable 2026-06-08 05:51:36.682860 Dalli Meta Protocol request_formatter.rb self.meta_set injection
LOW (3.7)
A vulnerability was found in Dalli up to 3.2.2. It has been classified as problematic. Affected is the function self.meta_set of the file lib/dalli/protocol/meta/request_formatter.rb of the component Meta Protocol Handler. The manipulation of the argument cas/ttl leads to injection. It is possible to launch the attack remotely. The complexity of an attack is rather high. The exploitability is told to be difficult. The exploit has been disclosed to the public and may be used. Upgrading to version 3.2.3 is able to address this issue. The patch is identified as 48d594dae55934476fec61789e7a7c3700e0f50d. It is recommended to upgrade the affected component.
Published: 2022-11-19T00:00:00.000Z
Updated: 2025-04-15T13:12:29.327Z
Reference links
Imported from gcve-enriched-dumps CVE data

Contribute

You can submit an edit proposal for this CPE entry or suggest a related product/vendor addition using the action button above.

Inspect record JSON

Open JSON directly

Open this panel to browse, search, copy or download the JSON record.