Stackstorm
Approved changes feed: RSS · Atom
cpe:2.3:a:stackstorm:stackstorm:*:*:*:*:*:*:*:*part: a version: * update: *
| Vendor | Stackstorm (8d0e87c1-764b-587b-baea-d71a92c97115) |
|---|---|
| Product | Stackstorm (806ddc68-b4a8-58b3-83a6-1fd1d24766ce) |
| Edition | * |
| Language | * |
| Software edition | * |
| Target software | * |
| Target hardware | * |
| Other | * |
Notes
Imported from purl2cpe mapping
PURL mappings
| PURL | Source | Last updated |
|---|---|---|
pkg:github/stackstorm/st2 |
purl2cpe | 2026-06-01 10:15:54.260337 |
pkg:sourceforge/stackstorm.mirror |
purl2cpe | 2026-06-01 10:15:54.260340 |
Vulnerability references
| Identifier | cpeApplicability | Submitted | db.gcve.eu details | Rationale |
|---|---|---|---|---|
CVE:CVE-2022-43706 |
vulnerable | 2026-06-08 05:49:33.858657 |
Details available
Cross-site scripting (XSS) vulnerability in the Web UI of StackStorm versions prior to 3.8.0 allowed logged in users with write access to pack rules to inject arbitrary script or HTML that may be executed in Web UI for other logged in users.
Published: 2022-12-05T00:00:00.000Z
Updated: 2025-04-24T13:57:41.968Z Reference links |
Imported from gcve-enriched-dumps CVE data |
CVE:CVE-2021-44657 |
vulnerable | 2026-06-08 05:36:46.445892 |
Details available
In StackStorm versions prior to 3.6.0, the jinja interpreter was not run in sandbox mode and thus allows execution of unsafe system commands. Jinja does not enable sandboxed mode by default due to backwards compatibility. Stackstorm now sets sandboxed mode for jinja by default.
Published: 2021-12-15T14:28:26.000Z
Updated: 2024-08-04T04:25:16.850Z |
Imported from gcve-enriched-dumps CVE data |
CVE:CVE-2021-28667 |
vulnerable | 2026-06-08 05:31:24.736251 |
Details available
StackStorm before 3.4.1, in some situations, has an infinite loop that consumes all available memory and disk space. This can occur if Python 3.x is used, the locale is not utf-8, and there is an attempt to log Unicode data (from an action or rule name).
Published: 2021-03-18T02:16:23.000Z
Updated: 2024-08-03T21:47:33.052Z |
Imported from gcve-enriched-dumps CVE data |
CVE:CVE-2019-9580 |
vulnerable | 2026-06-08 05:14:25.751695 |
Details available
In st2web in StackStorm Web UI before 2.9.3 and 2.10.x before 2.10.3, it is possible to bypass the CORS protection mechanism via a "null" origin value, potentially leading to XSS.
Published: 2019-03-09T04:00:00.000Z
Updated: 2024-08-04T21:54:45.092Z |
Imported from gcve-enriched-dumps CVE data |
CVE:CVE-2018-20345 |
vulnerable | 2026-06-08 05:11:27.077440 |
Details available
Incorrect access control in StackStorm API (st2api) in StackStorm before 2.9.2 and 2.10.x before 2.10.1 allows an attacker (who has a StackStorm account and is authenticated against the StackStorm API) to retrieve datastore items for other users by utilizing the /v1/keys "?scope=all" and "?user=<username>" query filter parameters. Enterprise editions with RBAC enabled are not affected.
Published: 2018-12-21T19:00:00.000Z
Updated: 2024-09-17T00:42:16.370Z |
Imported from gcve-enriched-dumps CVE data |
Contribute
You can submit an edit proposal for this CPE entry or suggest a related product/vendor addition using the action button above.
Inspect record JSON
Open this panel to browse, search, copy or download the JSON record.