Approved changes feed: RSS · Atom

cpe:2.3:a:arvados:arvados:*:*:*:*:*:*:*:*

part: a version: * update: *

VendorArvados (0be3c1e6-3ed2-56a8-b0a0-e2c44a46de76)
ProductArvados (271591cd-ac19-5e49-ac35-d9ff8b97744f)
Edition*
Language*
Software edition*
Target software*
Target hardware*
Other*
NotesImported from purl2cpe mapping

PURL mappings

PURLSourceLast updated
pkg:gem/arvados purl2cpe 2026-06-01 10:15:59.628595
pkg:github/exprobitasfiducia/arvados purl2cpe 2026-06-01 10:15:59.628598

Vulnerability references

IdentifiercpeApplicabilitySubmitteddb.gcve.eu detailsRationale
CVE:CVE-2022-39238 vulnerable 2026-06-08 05:47:18.407601 Improper Authentication in Arvados when using PAM as identity provider
MEDIUM (4.2)
Arvados is an open source platform for managing and analyzing biomedical big data. In versions prior to 2.4.3, when using Portable Authentication Modules (PAM) for user authentication, if a user presented valid credentials but the account is disabled or otherwise not allowed to access the host (such as an expired password), it would still be accepted for access to Arvados. Other authentication methods (LDAP, OpenID Connect) supported by Arvados are not affected by this flaw. This issue is patched in version 2.4.3. Workaround for this issue is to migrate to a different authentication method supported by Arvados, such as LDAP.
Published: 2022-09-23T08:05:08.000Z
Updated: 2025-04-23T16:55:59.303Z
Reference links
Imported from gcve-enriched-dumps CVE data
CVE:CVE-2022-36006 vulnerable 2026-06-08 05:46:06.135073 Authenticated remote code execution due to insecure deserialization (GHSL-2022-063)
HIGH (7.9)
Arvados is an open source platform for managing, processing, and sharing genomic and other large scientific and biomedical data. A remote code execution (RCE) vulnerability in the Arvados Workbench allows authenticated attackers to execute arbitrary code via specially crafted JSON payloads. This exists in all versions up to 2.4.1 and is fixed in 2.4.2. This vulnerability is specific to the Ruby on Rails Workbench application (“Workbench 1”). We do not believe any other Arvados components, including the TypesScript browser-based Workbench application (“Workbench 2”) or API Server, are vulnerable to this attack. For versions of Arvados earlier than 2.4.2: remove the Ruby-based "Workbench 1" app ("apt-get remove arvados-workbench") from your installation as a workaround.
Published: 2022-08-14T00:20:10.000Z
Updated: 2025-04-23T17:50:28.144Z
Reference links
Imported from gcve-enriched-dumps CVE data

Contribute

You can submit an edit proposal for this CPE entry or suggest a related product/vendor addition using the action button above.