Broadstreet
Approved changes feed: RSS · Atom
cpe:2.3:a:broadstreetads:broadstreet:*:*:*:*:*:*:*:*part: a version: * update: *
| Vendor | Broadstreetads (648e6804-6442-5854-8ce2-d32da49ae88f) |
|---|---|
| Product | Broadstreet (8ebcf574-4ff8-5986-8a0e-54a513234a08) |
| Edition | * |
| Language | * |
| Software edition | * |
| Target software | * |
| Target hardware | * |
| Other | * |
Notes
Imported from purl2cpe mapping
PURL mappings
| PURL | Source | Last updated |
|---|---|---|
pkg:github/broadstreetads/broadstreet-api-php |
purl2cpe | 2026-06-01 10:16:08.008067 |
pkg:github/broadstreetads/broadstreet-ruby |
purl2cpe | 2026-06-01 10:16:08.008070 |
pkg:github/broadstreetads/broadstreet-wp |
purl2cpe | 2026-06-01 10:16:08.008072 |
Vulnerability references
| Identifier | cpeApplicability | Submitted | db.gcve.eu details | Rationale |
|---|---|---|---|---|
CVE:CVE-2026-1881 |
vulnerable | 2026-06-08 07:49:09.798824 |
Broadstreet <= 1.52.2 - Authenticated (Subscriber+) Private Post Meta Disclosure via get_sponsored_meta
MEDIUM (4.3)
The Broadstreet plugin for WordPress is vulnerable to Insecure Direct Object Reference in all versions up to, and including, 1.52.2 via the get_sponsored_meta AJAX action due to missing validation on a user controlled key. This makes it possible for authenticated attackers, with Subscriber-level access and above, to disclose any private post metadata.
Published: 2026-05-21T01:26:15.241Z
Updated: 2026-05-21T14:24:56.187Z |
Imported from gcve-enriched-dumps CVE data |
CVE:CVE-2025-9989 |
vulnerable | 2026-06-08 07:47:10.412658 |
Broadstreet <= 1.53.1 - Authenticated (Admin+) Stored Cross-Site Scripting
MEDIUM (4.4)
The Broadstreet plugin for WordPress is vulnerable to Stored Cross-Site Scripting via admin settings in all versions up to, and including, 1.53.1 due to insufficient input sanitization and output escaping. This makes it possible for authenticated attackers, with administrator-level permissions and above, to inject arbitrary web scripts in pages that will execute whenever a user accesses an injected page. This only affects multi-site installations and installations where unfiltered_html has been disabled.
Published: 2026-05-13T04:26:41.904Z
Updated: 2026-05-13T10:21:26.150Z |
Imported from gcve-enriched-dumps CVE data |
CVE:CVE-2025-9988 |
vulnerable | 2026-06-08 07:47:10.412317 |
Broadstreet <= 1.53.1 - Missing Authorization to Authenticated (Subscriber+) Advertiser Creation
MEDIUM (4.3)
The Broadstreet plugin for WordPress is vulnerable to unauthorized access due to a missing capability check on the create_advertiser AJAX action in all versions up to, and including, 1.53.1. This makes it possible for authenticated attackers, with Subscriber-level access and above, to create advertisers.
Published: 2026-05-13T04:26:38.883Z
Updated: 2026-05-13T10:23:08.533Z |
Imported from gcve-enriched-dumps CVE data |
CVE:CVE-2025-9987 |
vulnerable | 2026-06-08 07:47:10.411924 |
Broadstreet <= 1.53.1 - Authenticated (Subscriber+) Information Disclosure
MEDIUM (5.3)
The Broadstreet plugin for WordPress is vulnerable to Sensitive Information Exposure in all versions up to, and including, 1.53.1 via the get_sponsored_meta() AJAX action. This makes it possible for authenticated attackers, with subscriber-level access and above, to extract data from password protected and private business details.
Published: 2026-05-13T04:26:40.666Z
Updated: 2026-05-13T10:22:09.908Z |
Imported from gcve-enriched-dumps CVE data |
CVE:CVE-2024-11825 |
vulnerable | 2026-06-08 06:23:50.462181 |
Broadstreet <= 1.51.0 - Authenticated (Contributor+) Stored Cross-Site Scripting via zone Parameter
MEDIUM (6.4)
The Broadstreet plugin for WordPress is vulnerable to Stored Cross-Site Scripting via the ‘zone’ parameter in all versions up to, and including, 1.51.0 due to insufficient input sanitization and output escaping. This makes it possible for authenticated attackers, with Contributor-level access and above, to inject arbitrary web scripts in pages that will execute whenever a user accesses an injected page.
Published: 2025-01-25T07:24:17.043Z
Updated: 2026-04-08T17:15:27.090Z Reference links
|
Imported from gcve-enriched-dumps CVE data |
Contribute
You can submit an edit proposal for this CPE entry or suggest a related product/vendor addition using the action button above.
Inspect record JSON
Open this panel to browse, search, copy or download the JSON record.