Approved changes feed: RSS · Atom

cpe:2.3:a:wprssaggregator:wp_rss_aggregator:*:*:*:*:*:wordpress:*:*

part: a version: * update: *

VendorWprssaggregator (3d317ccf-26f0-56a4-89b7-dd3ea380ef23)
ProductWp Rss Aggregator (a59d2b67-f7fa-5e02-8095-58e7c00a3528)
Edition*
Language*
Software edition*
Target softwarewordpress
Target hardware*
Other*

Notes

Imported from purl2cpe mapping

PURL mappings

PURLSourceLast updated
pkg:github/rebelcode/wp-rss-aggregato purl2cpe 2026-06-01 10:16:11.000267
pkg:github/wp-plugins/wp-rss-aggregator purl2cpe 2026-06-01 10:16:11.000269

Vulnerability references

IdentifiercpeApplicabilitySubmitteddb.gcve.eu detailsRationale
CVE:CVE-2024-0630 vulnerable 2026-06-08 06:22:01.537505 WP RSS Aggregator <= 4.23.4 - Authenticated (Admin+) Stored Cross-Site Scripting via RSS Feed Source
MEDIUM (4.4)
The WP RSS Aggregator plugin for WordPress is vulnerable to Stored Cross-Site Scripting via the RSS feed source in all versions up to, and including, 4.23.4 due to insufficient input sanitization and output escaping. This makes it possible for authenticated attackers, with administrator-level access, to inject arbitrary web scripts in pages that will execute whenever a user accesses an injected page. This only affects multi-site installations and installations where unfiltered_html has been disabled.
Published: 2024-02-05T21:21:53.514Z
Updated: 2026-04-08T17:09:45.128Z
Reference links
Imported from gcve-enriched-dumps CVE data
CVE:CVE-2024-0628 vulnerable 2026-06-08 06:22:01.531756 Details available
LOW (3.8)
The WP RSS Aggregator plugin for WordPress is vulnerable to Server-Side Request Forgery in all versions up to, and including, 4.23.5 via the RSS feed source in admin settings. This makes it possible for authenticated attackers, with administrator-level access and above, to make web requests to arbitrary locations originating from the web application and can be used to query and modify information from internal services.
Published: 2024-02-07T06:46:56.404Z
Updated: 2024-11-07T20:23:55.846Z
Reference links
Imported from gcve-enriched-dumps CVE data
CVE:CVE-2022-0189 vulnerable 2026-06-08 05:39:09.450617 WP RSS Aggregator < 4.20 - Reflected Cross-Site Scripting (XSS)
The WP RSS Aggregator WordPress plugin before 4.20 does not sanitise and escape the id parameter in the wprss_fetch_items_row_action AJAX action before outputting it back in the response, leading to a Reflected Cross-Site Scripting
Published: 2022-02-28T09:06:43.000Z
Updated: 2024-08-02T23:18:42.528Z
Reference links
Imported from gcve-enriched-dumps CVE data
CVE:CVE-2021-24988 vulnerable 2026-06-08 05:30:39.754609 WP RSS Aggregator < 4.19.3 - Subscriber+ Stored Cross-Site Scripting
The WP RSS Aggregator WordPress plugin before 4.19.3 does not sanitise and escape data before outputting it in the System Info admin dashboard, which could lead to a Stored XSS issue due to the wprss_dismiss_addon_notice AJAX action missing authorisation and CSRF checks, allowing any authenticated users, such as subscriber to call it and set a malicious payload in the addon parameter.
Published: 2021-12-27T10:33:24.000Z
Updated: 2024-08-03T19:49:14.547Z
Reference links
Imported from gcve-enriched-dumps CVE data
CVE:CVE-2021-24768 vulnerable 2026-06-08 05:30:39.201732 WP RSS Aggregator < 4.19.2 - Admin+ Stored Cross-Site Scripting
The WP RSS Aggregator WordPress plugin before 4.19.2 does not properly sanitise and escape the URL to Blacklist field, allowing malicious HTML to be inserted by high privilege users even when the unfiltered_html capability is disallowed, which could lead to Cross-Site Scripting issues.
Published: 2021-11-29T08:25:36.000Z
Updated: 2024-08-03T19:42:17.221Z
Reference links
Imported from gcve-enriched-dumps CVE data

Contribute

You can submit an edit proposal for this CPE entry or suggest a related product/vendor addition using the action button above.

Inspect record JSON

Open JSON directly

Open this panel to browse, search, copy or download the JSON record.