Approved changes feed: RSS · Atom

cpe:2.3:a:netalertx:netalertx:*:*:*:*:*:*:*:*

part: a version: * update: *

VendorNetalertx (ad4ce111-d71a-5fd2-92dd-962af391113d)
ProductNetalertx (209b0cf3-a35a-5da0-9c3a-1692fe2c0b54)
Edition*
Language*
Software edition*
Target software*
Target hardware*
Other*

Notes

Imported from purl2cpe mapping

PURL mappings

PURLSourceLast updated
pkg:github/jokob-sk/netalertx purl2cpe 2026-06-01 10:16:18.572450

Vulnerability references

IdentifiercpeApplicabilitySubmitteddb.gcve.eu detailsRationale
CVE:CVE-2025-48952 vulnerable 2026-06-08 07:29:12.299011 NetAlertX has Password Bypass Vulnerability due to Loose Comparison in PHP
CRITICAL (9.4)
NetAlertX is a network, presence scanner, and alert framework. Prior to version 25.6.7, a vulnerability in the authentication logic allows users to bypass password verification using SHA-256 magic hashes, due to loose comparison in PHP. In vulnerable versions of the application, a password comparison is performed using the `==` operator at line 40 in front/index.php. This introduces a security issue where specially crafted "magic hash" values that evaluate to true in a loose comparison can bypass authentication. Because of the use of `==` instead of the strict `===`, different strings that begin with 0e and are followed by only digits can be interpreted as scientific notation (i.e., zero) and treated as equal. This issue falls under the Login Bypass vulnerability class. Users with certain "weird" passwords that produce magic hashes are particularly affected. Services relying on this logic are at risk of unauthorized access. Version 25.6.7 fixes the vulnerability.
Published: 2025-07-04T22:12:54.601Z
Updated: 2025-07-08T13:51:33.982Z
Reference links
Imported from gcve-enriched-dumps CVE data
CVE:CVE-2025-32440 vulnerable 2026-06-08 07:18:59.795876 NetAlertX Vulnerable to Authentication Bypass
CRITICAL (10)
NetAlertX is a network, presence scanner and alert framework. Prior to version 25.4.14, it is possible to bypass the authentication mechanism of NetAlertX to update settings without authentication. An attacker can trigger sensitive functions within util.php by sending crafted requests to /index.php. This issue has been patched in version 25.4.14.
Published: 2025-05-27T21:59:40.497Z
Updated: 2025-05-28T13:45:52.417Z
Reference links
Imported from gcve-enriched-dumps CVE data
CVE:CVE-2024-48766 vulnerable 2026-06-08 06:50:09.856300 Details available
HIGH (8.6)
NetAlertX 24.7.18 before 24.10.12 allows unauthenticated file reading because an HTTP client can ignore a redirect, and because of factors related to strpos and directory traversal, as exploited in the wild in May 2025. This is related to components/logs.php.
Published: 2025-05-13T00:00:00.000Z
Updated: 2025-05-13T19:53:28.974Z
Reference links
Imported from gcve-enriched-dumps CVE data
CVE:CVE-2024-46506 vulnerable 2026-06-08 06:48:10.125185 Details available
CRITICAL (10)
NetAlertX 23.01.14 through 24.x before 24.10.12 allows unauthenticated command injection via settings update because function=savesettings lacks an authentication requirement, as exploited in the wild in May 2025. This is related to settings.php and util.php.
Published: 2025-05-13T00:00:00.000Z
Updated: 2025-05-13T19:09:51.072Z
Reference links
Imported from gcve-enriched-dumps CVE data

Contribute

You can submit an edit proposal for this CPE entry or suggest a related product/vendor addition using the action button above.

Inspect record JSON

Open JSON directly

Open this panel to browse, search, copy or download the JSON record.