Approved changes feed: RSS · Atom

cpe:2.3:a:weformspro:weforms:*:*:*:*:*:wordpress:*:*

part: a version: * update: *

VendorWeformspro (e55d9768-ab45-53ed-ab4b-48b117aaab79)
ProductWeforms (978a0363-65ea-5ae3-bb58-6c96924dab4b)
Edition*
Language*
Software edition*
Target softwarewordpress
Target hardware*
Other*

Notes

Imported from purl2cpe mapping

PURL mappings

PURLSourceLast updated
pkg:github/boldgrid/weforms purl2cpe 2026-06-01 10:16:21.863865

Vulnerability references

IdentifiercpeApplicabilitySubmitteddb.gcve.eu detailsRationale
CVE:CVE-2024-32512 vulnerable 2026-06-08 06:35:33.267650 WordPress weForms plugin <= 1.6.20 - Form Submission Restriction Bypass vulnerability
MEDIUM (5.3)
Client-Side Enforcement of Server-Side Security vulnerability in weForms allows Removing Important Client Functionality.This issue affects weForms: from n/a through 1.6.20.
Published: 2024-05-17T08:56:41.369Z
Updated: 2026-04-28T16:09:35.970Z
Reference links
Imported from gcve-enriched-dumps CVE data
CVE:CVE-2024-30512 vulnerable 2026-06-08 06:35:30.494238 WordPress weForms plugin <= 1.6.20 - Broken Access Control vulnerability
LOW (3.7)
Missing Authorization vulnerability in weForms.This issue affects weForms: from n/a through 1.6.20.
Published: 2024-06-09T10:59:42.461Z
Updated: 2026-04-28T16:09:25.814Z
Reference links
Imported from gcve-enriched-dumps CVE data
CVE:CVE-2024-0386 vulnerable 2026-06-08 06:22:00.501006 weForms <= 1.6.21 - Unauthenticated Stored Cross-Site Scripting via Referer
HIGH (7.2)
The weForms plugin for WordPress is vulnerable to Stored Cross-Site Scripting via the 'Referer' HTTP header in all versions up to, and including, 1.6.21 due to insufficient input sanitization and output escaping. This makes it possible for unauthenticated attackers to inject arbitrary web scripts in pages that will execute whenever a user accesses an injected page.
Published: 2024-03-12T21:34:34.174Z
Updated: 2026-04-08T17:33:05.373Z
Reference links
Imported from gcve-enriched-dumps CVE data
CVE:CVE-2023-51524 vulnerable 2026-06-08 06:17:53.415107 WordPress weForms plugin <= 1.6.18 - Broken Access Control vulnerability
MEDIUM (4.3)
Missing Authorization vulnerability in weForms.This issue affects weForms: from n/a through 1.6.18.
Published: 2024-06-12T09:09:59.874Z
Updated: 2026-04-28T16:09:03.744Z
Reference links
Imported from gcve-enriched-dumps CVE data
CVE:CVE-2023-50896 vulnerable 2026-06-08 06:16:16.967847 WordPress weForms Plugin <= 1.6.17 is vulnerable to Cross Site Scripting (XSS)
MEDIUM (5.9)
Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting') vulnerability in weForms weForms – Easy Drag & Drop Contact Form Builder For WordPress allows Stored XSS.This issue affects weForms – Easy Drag & Drop Contact Form Builder For WordPress: from n/a through 1.6.17.
Published: 2023-12-29T11:09:16.175Z
Updated: 2026-04-28T16:09:00.620Z
Reference links
Imported from gcve-enriched-dumps CVE data
CVE:CVE-2022-2395 vulnerable 2026-06-08 05:43:35.465219 db.gcve.eu details were skipped to keep the page responsive. Imported from gcve-enriched-dumps CVE data

Contribute

You can submit an edit proposal for this CPE entry or suggest a related product/vendor addition using the action button above.

Inspect record JSON

Open JSON directly

Open this panel to browse, search, copy or download the JSON record.