Enable Media Replace
Approved changes feed: RSS · Atom
cpe:2.3:a:shortpixel:enable_media_replace:*:*:*:*:*:*:*:*part: a version: * update: *
| Vendor | Shortpixel (0b5f855a-971d-5a8c-9e7a-25a449664847) |
|---|---|
| Product | Enable Media Replace (bed5a5f3-6882-5d4d-8664-c50635e6bdb8) |
| Edition | * |
| Language | * |
| Software edition | * |
| Target software | * |
| Target hardware | * |
| Other | * |
Notes
Imported from purl2cpe mapping
PURL mappings
| PURL | Source | Last updated |
|---|---|---|
pkg:github/short-pixel-optimizer/enable-media-replace |
purl2cpe | 2026-06-01 10:16:36.165682 |
Vulnerability references
| Identifier | cpeApplicability | Submitted | db.gcve.eu details | Rationale |
|---|---|---|---|---|
CVE:CVE-2026-85655 |
vulnerable | 2026-11-03 10:16:23.628681 |
Enable Media Replace <= 4.2.2 - Missing Authorization to Authenticated (Author+) Post Content Modification via Media Replacement Workflow
MEDIUM (4.3)
The Enable Media Replace plugin for WordPress is vulnerable to authorization bypass in all versions up to, and including, 4.2.2. This is due to the plugin not properly verifying that a user is authorized to perform an action. This makes it possible for authenticated attackers, with author-level access and above, to modify the post_content of any published post referencing the replaced media — including Administrator-owned posts — making changes immediately visible to unauthenticated visitors. The doReplaceQuery() method performs a database-wide search-and-replace across all posts containing the old media URL without any per-post capability check, meaning a single Author-triggered request can silently overwrite a large number of posts that WordPress's standard admin UI and REST API would otherwise forbid that user from editing.
Published: 2026-10-28T07:48:29.420Z
Updated: 2026-10-29T01:41:49.939Z Reference links
|
Imported from gcve-enriched-dumps CVE data |
CVE:CVE-2026-5714 |
vulnerable | 2026-07-29 01:03:23.415072 |
Enable Media Replace <= 4.1.8 - Authenticated (Author+) Stored Cross-Site Scripting via 'location_dir' Parameter
MEDIUM (6.4)
The Enable Media Replace plugin for WordPress is vulnerable to Stored Cross-Site Scripting via the ‘location_dir’ parameter in all versions up to, and including, 4.1.8 due to insufficient input sanitization and output escaping. This makes it possible for authenticated attackers, with Author-level access and above, to inject arbitrary web scripts in pages that will execute whenever a user accesses an injected page.
Published: 2026-06-09T02:28:48.806Z
Updated: 2026-06-09T14:13:19.684Z Reference links
|
Imported from gcve-enriched-dumps CVE data |
CVE:CVE-2026-57722 |
vulnerable | 2026-07-29 01:03:16.110725 |
WordPress Enable Media Replace plugin <= 4.2.1 - Cross Site Scripting (XSS) vulnerability
MEDIUM (5.9)
Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting') vulnerability in ShortPixel Enable Media Replace allows Stored XSS.
This issue affects Enable Media Replace: from n/a through 4.2.1.
Published: 2026-07-01T17:07:22.030Z
Updated: 2026-07-02T14:33:30.032Z |
Imported from gcve-enriched-dumps CVE data |
CVE:CVE-2026-2732 |
vulnerable | 2026-06-08 07:55:17.440635 |
Enable Media Replace <= 4.1.7 - Improper Authorization to Authenticated (Author+) Arbitrary Attachment Change via Background Replace
MEDIUM (5.4)
The Enable Media Replace plugin for WordPress is vulnerable to unauthorized modification of data due to an improper capability check on the 'RemoveBackGroundViewController::load' function in all versions up to, and including, 4.1.7. This makes it possible for authenticated attackers, with Author-level access and above, to replace any attachment with a removed background attachment.
Published: 2026-03-04T06:26:53.170Z
Updated: 2026-04-08T16:43:53.355Z Reference links
|
Imported from gcve-enriched-dumps CVE data |
CVE:CVE-2025-9496 |
vulnerable | 2026-06-08 07:45:22.582853 |
Enable Media Replace <= 4.1.6 - Authenticated (Contributor+) Stored Cross-Site Scripting via file_modified Shortcode
MEDIUM (6.4)
The Enable Media Replace plugin for WordPress is vulnerable to Stored Cross-Site Scripting via the plugin's file_modified shortcode in all versions up to, and including, 4.1.6 due to insufficient input sanitization and output escaping on user supplied attributes. This makes it possible for authenticated attackers, with contributor-level access and above, to inject arbitrary web scripts in pages that will execute whenever a user accesses an injected page.
Published: 2025-10-11T07:25:55.744Z
Updated: 2026-04-08T16:34:02.835Z Reference links
|
Imported from gcve-enriched-dumps CVE data |
CVE:CVE-2025-31081 |
vulnerable | 2026-06-08 07:17:02.333250 | db.gcve.eu details were skipped to keep the page responsive. | Imported from gcve-enriched-dumps CVE data |
CVE:CVE-2023-6737 |
vulnerable | 2026-06-08 06:21:55.529400 | db.gcve.eu details were skipped to keep the page responsive. | Imported from gcve-enriched-dumps CVE data |
Contribute
You can submit an edit proposal for this CPE entry or suggest a related product/vendor addition using the action button above.
Inspect record JSON
Open this panel to browse, search, copy or download the JSON record.