Approved changes feed: RSS · Atom

cpe:2.3:a:webmovementllc:foxypress:*:*:*:*:*:*:*:*

part: a version: * update: *

VendorWebmovementllc (b302ded3-6805-565a-8c16-ab95748f3fb2)
ProductFoxypress (a2dd84af-6de4-5e56-ab2a-9304035aac9d)
Edition*
Language*
Software edition*
Target software*
Target hardware*
Other*

Notes

Imported from purl2cpe mapping

PURL mappings

PURLSourceLast updated
pkg:github/thomascrenshaw/foxypress purl2cpe 2026-06-01 10:16:39.633829

Vulnerability references

IdentifiercpeApplicabilitySubmitteddb.gcve.eu detailsRationale
CVE:CVE-2012-10020 vulnerable 2026-06-08 05:00:46.872508 FoxyPress <= 0.4.2.1 - Arbitrary File Upload
CRITICAL (9.8)
The FoxyPress plugin for WordPress is vulnerable to arbitrary file uploads due to missing file type validation in the uploadify.php file in versions up to, and including, 0.4.2.1. This makes it possible for unauthenticated attackers to upload arbitrary files on the affected sites server which may make remote code execution possible.
Published: 2025-07-22T01:44:29.019Z
Updated: 2026-04-08T17:06:37.942Z
Reference links
Imported from gcve-enriched-dumps CVE data

Contribute

You can submit an edit proposal for this CPE entry or suggest a related product/vendor addition using the action button above.

Inspect record JSON

Open JSON directly

Open this panel to browse, search, copy or download the JSON record.