Approved changes feed: RSS · Atom
cpe:2.3:a:lua:lua:*:*:*:*:*:*:*:*part: a version: * update: *
| Vendor | Lua (5d64284d-58d7-55d2-8192-84bb490cef71) |
|---|---|
| Product | Lua (6cff8272-4f1a-522a-a6b7-be7cfb9d18e1) |
| Edition | * |
| Language | * |
| Software edition | * |
| Target software | * |
| Target hardware | * |
| Other | * |
Notes
Imported from purl2cpe mapping
PURL mappings
| PURL | Source | Last updated |
|---|---|---|
pkg:github/lua/lua |
purl2cpe | 2026-06-01 10:16:42.650577 |
pkg:rpm/centos/lua |
purl2cpe | 2026-06-01 10:16:42.650579 |
pkg:rpm/fedora/lua |
purl2cpe | 2026-06-01 10:16:42.650580 |
Vulnerability references
| Identifier | cpeApplicability | Submitted | db.gcve.eu details | Rationale |
|---|---|---|---|---|
CVE:CVE-2022-33099 |
vulnerable | 2026-06-08 05:44:46.219593 |
Details available
An issue in the component luaG_runerror of Lua v5.4.4 and below leads to a heap-buffer overflow when a recursive error occurs.
Published: 2022-07-01T11:26:38.000Z
Updated: 2024-08-03T08:01:20.153Z Reference links
|
Imported from gcve-enriched-dumps CVE data |
CVE:CVE-2022-28805 |
vulnerable | 2026-06-08 05:42:45.827719 |
Details available
singlevar in lparser.c in Lua from (including) 5.4.0 up to (excluding) 5.4.4 lacks a certain luaK_exp2anyregup call, leading to a heap-based buffer over-read that might affect a system that compiles untrusted Lua code.
Published: 2022-04-08T00:00:00.000Z
Updated: 2024-08-03T06:03:53.085Z Reference links
|
Imported from gcve-enriched-dumps CVE data |
CVE:CVE-2021-45985 |
vulnerable | 2026-06-08 05:36:49.645828 |
Details available
In Lua 5.4.3, an erroneous finalizer called during a tail call leads to a heap-based buffer over-read.
Published: 2023-04-10T00:00:00.000Z
Updated: 2025-02-12T16:02:20.735Z |
Imported from gcve-enriched-dumps CVE data |
CVE:CVE-2021-44964 |
vulnerable | 2026-06-08 05:36:47.651653 |
Details available
Use after free in garbage collector and finalizer of lgc.c in Lua interpreter 5.4.0~5.4.3 allows attackers to perform Sandbox Escape via a crafted script file.
Published: 2022-03-14T14:24:51.000Z
Updated: 2024-08-04T04:32:13.466Z Reference links |
Imported from gcve-enriched-dumps CVE data |
CVE:CVE-2021-43519 |
vulnerable | 2026-06-08 05:36:43.477025 |
Details available
Stack overflow in lua_resume of ldo.c in Lua Interpreter 5.1.0~5.4.4 allows attackers to perform a Denial of Service via a crafted script file.
Published: 2021-11-09T12:26:22.000Z
Updated: 2024-08-04T03:55:29.081Z Reference links
|
Imported from gcve-enriched-dumps CVE data |
CVE:CVE-2021-32921 |
not_vulnerable | 2026-06-08 05:32:08.195678 | db.gcve.eu details were skipped to keep the page responsive. | Imported from gcve-enriched-dumps CVE data |
CVE:CVE-2020-15945 |
vulnerable | 2026-06-08 05:19:27.222831 | db.gcve.eu details were skipped to keep the page responsive. | Imported from gcve-enriched-dumps CVE data |
Contribute
You can submit an edit proposal for this CPE entry or suggest a related product/vendor addition using the action button above.
Inspect record JSON
Open this panel to browse, search, copy or download the JSON record.